phone only registers with private IP, not public

VitalPBX Community Support General Discussion phone only registers with private IP, not public

  • Post
    dashrender
    Participant

    I have a fresh install of VitalPBX 2.3.6-1 installed in Vultr.  The PBX has a real IP and it’s directly on the internet, no NAT for the PBX.

    I’ve added an extension, and setup my Yealink T22P and the phone registers.  In fact I can use the phone to make outgoing calls.

    My issue is calling between extensions or incoming calls being directed to the ext – they don’t work, message is There is no route to destination.

    The Extension Status show the IP of the phone as it’s private IP, not it’s public one.  The phone behind a Unifi USG firewall.  I had the same issues behind a SonicWall and an Unifi EdgeRouter-X.

    I don’t have a private IP to setup in NAT on the PBX, since the PBX is not behind NAT, so I’m not sure what settings I need to change.

    Any thoughts?

    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • Replies
    Up
    0
    Down

    Usually, when you have a cloud VPS, you must define on the SIP Settings your public IP address or domain and set the NAT parameter to “Force,Comedia” (Check the attached picture).

    Another thing you have to take into account is the network configurations on the phone side, so, if the PBX shows the internal IP address, maybe its because the router is overwritten the SIP headers sent to the PBX. Also, you have to make sure get disabled the “SIP ALG” option on your router (if this option is present).

    When you hear the message “There is no route to the destination.” on an incoming call is because you didn’t configure the correct DID. What you have to do in this cases is to check the asterisk console and verify the log output and determinate what is really happening, and why the message is played.

    0
    dashrender
    Participant
    Up
    0
    Down

    Thanks for that.
    My trunk from Skyetel and my phones are all PJSIP, does that make a difference?

     

    0
    Up
    0
    Down

    I recommend you to try connecting your phone using SIP protocol

    0
    dashrender
    Participant
    Up
    0
    Down

    I’ve made progress – thanks.

    I’ve swapped the Ext to a SIP trunk – it now registers with the real IP of the network it’s attached to.

    and @mrivera was right – I had the wrong number in the Inbound Trunk, corrected that, got a new error message “no route exists to the dialed destination”

    My carrier trunk is PJSIP and works fine… but I can’t get my phones to work on PJSIP. UG!

    0
    Up
    0
    Down

    Try with the RC version of VitalPBX, on version 2.3.7 (RC), we have released some new configurations for PJSIP

    0
Viewing 5 replies - 1 through 5 (of 5 total)

Tagged: ,

  • You must be logged in to reply to this topic.