PJSIP Trunk Problems, please help!

VitalPBX Community Support General Discussion PJSIP Trunk Problems, please help!

  • Post
    Tuxheader
    Participant
    Up
    0
    Down
    Hello.

    We have a new installation in process, as you know today, VitalPBX changed the default protocol, from SIP to PJSIP, the problem is perceived with two traditional PSTN providers, one in the cloud and the other on the ground, both with SIP protocol.

    The phenomenon that we have with the cloud provider is that there is no audio in any way.
    We reviewed the VitalPBX database of knowledge and cases presented by Don Rodrigo, and thanks to these scenarios we managed to register the trunk in the cloud, but without audio in outgoing calls. We review the call frames via Asterisk CLI and in turn via SNGREP, there are no errors of any kind that can guide us and find the error.Incoming calls do not even reach the VitalPBX, for this reason I cannot see any data of the call frames.

    Since we had to put the process on hold, we performed the same scenario in our Site in a separate system, we tested it with two versions of VitalPBX: Ver. 3.0.6-2 with Asterisk 18.1.1 and now with the new version: VitalPBX Ver: 3.0.8-1 which comes with Asterisk Ver: 18.3.0. And in both versions we have the same problems.

    Continuing, we also made tests with different recommendations that we found in the VitalPBX forum, as well as several configuration recommendations that Rodrígo Cuadra, we made a series of modifications taken from other scenarios with other brands seeing the pjsip.conf, but we were not lucky either.

    As you know the forms of the profile of the SIP protocol for trunk registration is radically different from that of PJSIP, for this reason we attach a screenshot with a SIP trunk with the same cloud provider that does work and another screenshot of how we have configured it. trunk only that the PJSIP protocol, the idea is that they can guide us to see what we are doing wrong and thus manage to register the connection, and the audio Works.

    Screenshots list names:  Sensitive data is not published and is replaced by generic names.

    1. SIP Example Works.png
    2. PJSIP Example NO audio two ways.png
    3. pjsip show endpoints.png
    4. pjsip show registrations.png
    5. NAT-PJSIP Settings.png
    
    

    We look forward to your comments, we are at your service!

     

    Best Regards!!!

     

    Attachments:
    You must be logged in to view attached files.
    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • Replies
    Tuxheader
    Participant
    Up
    0
    Down
    Test!
    0
    slemoal
    Participant
    Up
    0
    Down
    hello can you call and be called?

    if yes so when you answer does the call hang up? if not,  it’s more of an rtp stream problem. did you open these? port from 10000 to 20000. are you using srtp?

    0
    Up
    0
    Down
    In the “Default PJSIP profile” try disabling the parameters “Direct Media” and “Disable NAT Direct Media”. In addition, you should enable the RTP’s debug to see between which IPs the audio traffic is flowing.

    rtp set debug on

    0
    Tuxheader
    Participant
    Up
    0
    Down
    José.

     

    Thanks! I’ll make the adjustments and test.

    Then I’ll tell you how it went. 😀

    Best regards!

    0
    Tuxheader
    Participant
    Up
    0
    Down
    Slemoal.

     

    With the configuration you saw in the screenshots, the only way I was able to call out, but the incoming calls DO NOT work, I will perform the tests based on the recommendations of our dear friend José Rivera, then I will deliver as it went.

     

    Thanks!

    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.