Prevent trunk from asking authentication

VitalPBX Community Support General Discussion Prevent trunk from asking authentication

Up
0
Down
  • Post
    g.wolzak
    Participant

    Hello All,

    Newbie on the VitalPBX, not new on asterisk.

    I have setup VitalPBX, with the vps script verry nice…, with a Kamailio in front.

    Configured hotdesking. 

    Phones register on the Kamailio and then kamailio forwards the registration to VitalPBX.

    Calls work, audio is flowing. 

    No problems here.

    When a phone calls, the invite gets challenged by Kamailio, after that the call is routed to the VitalPBX, the PBX also challenges the invite. That is what I want to prevent. Authentication is already done by Kamailo, no need for Vital to do that again.

     

    When I use a vanilla Asterisk, I just configure a trunk like this.

    [cbsbc](!)
    disallow=all
    allow=alaw
    allow=gsm
    type=peer
    insecure=no
    qualify=4000
    nat=no
    context = from-pstn

    [sipproxy01](cbsbc)
    host=ex.ter.nal.ip (of the kamailio)
    port = 5060

    When a call is send from the kamailio asterisk just handles the call, no 401 Unauthorized is sent.

    Now I am trying to configure trunk on the VitalPBX to do the same but no luck.

    I have configured a profile for the kamailio:

    ;Trunk Proxy01 Profile – Profile voor sipproxy01
    [p12](!)
    host = ex.ter.nal.ip
    trustrpid = yes
    sendrpid = no
    type = peer
    qualify = 2000
    qualifyfreq = 60
    transport = udp
    avpf = no
    directmedia = nonat
    icesupport = no
    encryption = no
    dtlsenable = no
    dtlsverify = no
    dtlssetup = actpass
    dtlsfingerprint = sha-256
    dtlsrekey = 0
    force_avp = no
    rtcp_mux = no
    insecure = no

    And the trunk itself as

    [sipproxy01](p12)
    context=trk-1-in
    description=SIPPROXY01
    dtmfmode=rfc2833
    allow=!all,ulaw,alaw
    nat=no
    host=ex.ter.nal.ip (of the kamailio)
    port=5060
    type=friend
    qualify=yes
    canreinvite=no

    The configs above are done via the VitalPBX interface, just more clear then screenprints.

    But these configurations do not prevent the 401 Unauthorized challenges from being sent back to the Kamailio.

    I also have tried with the insecure=port,invite setting, but makes no difference.

    I must be doing something wrong…

    Any tips,advise or links to documentation would be appreciated.

    Rgds,

    Gertjan 

     

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies

    Try to debug the registration using sngrep tool

    0
    g.wolzak
    Participant

    I dont understand… Why use the debug tool to check the registration?

    Nothing is going wrong with the registration, all works well….

    I want the PBX just to accept invites which are routed from the kamailio servers, without challenging the invite.

    Which comes down to authentication based on source ip.

    I cant get that configured correctly.

    0

    That’s why you need to debug, to see what is Kamailio sending, and what the PBX is responding.

    Now, remember that in VitalPBX it is possible to create plain text mode trunk, just in case you have a configuration that already works fine.

    0
    g.wolzak
    Participant

    Thank you, I will look into the plain text mode trunk.

    Rgds,

    Gertjan

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.