Problem configuring SIP trunk with Telco (It works @ Elastix 2.5)

VitalPBX Community Support General Discussion Problem configuring SIP trunk with Telco (It works @ Elastix 2.5)

Up
0
Down
  • Post
    cdcambronero
    Participant

    Hello, 

     

    First of all, I’d like to thank you to provide this first class software to all the community, It came in the precise moment to cover the gap that Elastix left.

    This is my first migration from Elastix 2.5 to VitalPBX, I did everything manually and everything works good, except the trunk with my Sip phone provider (Tigo in Costa Rica), I already have the following configuration working within the elastix 2.5 and it work fine (The rest of the field on the trunk configuration are in blank including the registry string):

     Elastix

    This is the configuration of the Outbound route at the elastix:

     

    Elastix_Out

     

    This is the trunk configuration at my VitalPBX

    Vital_1 Vital_2 Vital_3

    This is the configuration for my ourbout route at my VitalPBX:

    Vital_Out

     

    The intersting part is with this setup at the VitalPBX I’m able to receive the call with no isssue, but when I try to make calls to the outside (With and without pinset configured at the outbound route) the call get a Busy tone and at the console I can see a 603 error (I double checked that the Number that I’m sending to the telco is correct)

    I tried to troubleshoot by changing the NAT seting to everyone possible at the GUI with no success and I also disables All the advanced options that I had configured.

    I hope you can bring me some advise as at this point I’m lost… Thanks in advanced for any help.

    Regards, 

     

    PS: Tomorrow August/14/2018 at 7:30am -6GMT I’ll have a troubleshooting session with my Telco, if I found something I’ll let you know.

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • Replies
    cdcambronero
    Participant

    Well… My Telco didin’t call me…

     

    I took the time to collect the following logs:

    https://1drv.ms/f/s!AtQ_ragF27mEhfA0_oKfdw3w4eg8UQ

     

    I also copied as I could the Trunk configuration from the Elastix and replicate it on the file at the VialPBX and the restarted the asterisk core but it didin’t worked.

    I copied the Elastix trunk configuration to the file: /etc/asterisk/sip__50-1-trunks.conf and then restarted the cli with the command core restart now 

     

    Thanks in advanced again. 

    0

    How many ethernet interfaces do you have?

    What is the Version of VitalPBX?

    0
    cdcambronero
    Participant

    Thanks for your reply!

    I have 2 Ethernet interfaces, 2 configured with the proper routes, the telco SIP-Trunk interface (ETH2) has an static route for the destination PBX for my Telco the default route is configured on the ETH1.

    Please also keep in mind that incoming calls are working with this configuration with that same trunk, but on VitalPBX outgoing not work and elastix does.

    VitalPBX: version (2.0.4-4)|Asterisk 13.21.0-1 | DAHDI 2.11.1-6

    ETH1 IP: 10.0.0.1/22 

    ETH1: 10.12.14.166/30 (Moving the cable from Elastix the cable while testing)

    [root@grupobelenpbx ~]# route
    Kernel IP routing table
    Destination                                         Gateway                                     Genmask                         Flags                      Metric                 Ref                       Use                           Iface
    default                                                gateway                                        0.0.0.0                             UG                            101                     0                            0                               eth1
    default                                                gateway                                       0.0.0.0                              UG                           102                     0                            0                                eth0
    10.0.0.0                                              0.0.0.0                                     255.255.252.0                      U                              102                     0                           0                                  eth0
    10.7.52.1                                             gateway                                  255.255.255.255                  UGH                         90                      0                           0                                   eth1
    10.12.14.164                                       0.0.0.0                                    255.255.255.252                   U                              101                      0                          0                                    eth1

     

     

    Elastix: Linux 2.6.18 | Elastix 2.4.0-8 | Elastix System 2.5.0-2 | Asterisk 11.17.1-1

    ETH0: 10.0.0.233/22

    ETH1: 10.12.14.166/30 (Moving the cable from VitalPBX the cable while testing)

    Routes:

    [root@pbx ~]# route
    Kernel IP routing table
    Destination                Gateway                      Genmask              Flags              Metric          Ref          Use                  Iface
    10.7.52.1                   10.12.14.165             255.255.255.255        UGH                  0                 0             0                      eth1
    10.12.14.164                  *                            255.255.255.252        U                        0                 0             0                      eth1
    10.0.0.0                         *                            255.255.252.0            U                        0                 0             0                      eth0
    default                   firewall.grupob              0.0.0.0                   UG                     0                 0             0                      eth0

    0

    Please, post a call log of an outgoing call in VitalPBX

     

    0
    cdcambronero
    Participant

    Does this one work?

    https://1drv.ms/t/s!AtQ_ragF27mEhfA3uOvYggcVEAYndQ 

    Extension Number: 1500

    Destination number 89643348

    Prefix for outbound route: 9

    Number dialed: 989643348

    Trunk Name: Tigo

    0

    Looks like you forgot to setup the Outbound Caller ID (Example Attached).

    If setting up the caller id doesn’t fix the issue, ask to your VoIP provider about this message: Got SIP response 603 “ANI ERROR” back from 10.7.52.1:5060

    0
    cdcambronero
    Participant

    Thanks! I’ll check it out and let you know.

    Thanks

    0
    cdcambronero
    Participant

    Sorry, one more question…

    Is there a way to avoid 1 specific extension to use PIN Sets?

    0

    You may enable the pinless option per extension under the advanced tab. (Example attached)

    0
    cdcambronero
    Participant

    LoL… Thank you so much!

    0

    What about outbound calls? are working now?

    0
    cdcambronero
    Participant

    I’ll have to wait until Thursday to test… Tomorrow is a holiday here in Costa Rica and I’m no longer at the location.

    0
Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.