Problem upgrading to 2.1.0-3

VitalPBX Community Support General Discussion Problem upgrading to 2.1.0-3

Up
0
Down
  • Post
    Tassos
    Participant

    I tried to upgrade to 2.1.0-3 through the GUI interface and I got an error at the and.

    The upgrade process did not finish properly, probably.

    I tried the to upgrade through the shell with yum update and I got the following. Is it possible to fix it or do I have to reinstall vitalPBX?

    [root@dispan-vitalpbx ~]# yum update
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    * base: http://ftp.otenet.gr
    * epel: http://ftp.linux.org.tr
    * extras: http://ftp.otenet.gr
    * updates: http://ftp.otenet.gr
    Resolving Dependencies
    –> Running transaction check
    —> Package vitalpbx-monitor.x86_64 0:2.1.0-1 will be updated
    –> Processing Dependency: vitalpbx-monitor = 2.1.0-1 for package: vitalpbx-2.1.0-1.x86_64
    —> Package vitalpbx-monitor.x86_64 0:2.1.0-3 will be an update
    –> Finished Dependency Resolution
    Error: Package: vitalpbx-2.1.0-1.x86_64 (@anaconda/2.1)
    Requires: vitalpbx-monitor = 2.1.0-1
    Removing: vitalpbx-monitor-2.1.0-1.x86_64 (@anaconda/2.1)
    vitalpbx-monitor = 2.1.0-1
    Updated By: vitalpbx-monitor-2.1.0-3.x86_64 (vpbx)
    vitalpbx-monitor = 2.1.0-3
    Available: vitalpbx-monitor-2.0.0-1b.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-1b
    Available: vitalpbx-monitor-2.0.0-2b.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-2b
    Available: vitalpbx-monitor-2.0.0-3b.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-3b
    Available: vitalpbx-monitor-2.0.0-4rc1.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-4rc1
    Available: vitalpbx-monitor-2.0.0-4rc2.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-4rc2
    Available: vitalpbx-monitor-2.0.0-5.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-5
    Available: vitalpbx-monitor-2.0.0-6.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.0-6
    Available: vitalpbx-monitor-2.0.1-1.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.1-1
    Available: vitalpbx-monitor-2.0.2-1.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.2-1
    Available: vitalpbx-monitor-2.0.2-2.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.2-2
    Available: vitalpbx-monitor-2.0.3-1.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.3-1
    Available: vitalpbx-monitor-2.0.3-2.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.3-2
    Available: vitalpbx-monitor-2.0.3-3.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.3-3
    Available: vitalpbx-monitor-2.0.4-1.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.4-1
    Available: vitalpbx-monitor-2.0.4-2.x86_64 (vpbx)

    vitalpbx-monitor = 2.0.4-2
    Available: vitalpbx-monitor-2.0.4-3.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.4-3
    Available: vitalpbx-monitor-2.0.4-4.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.4-4
    Available: vitalpbx-monitor-2.0.5-1.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.5-1
    Available: vitalpbx-monitor-2.0.5-2.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.5-2
    Available: vitalpbx-monitor-2.0.5-3.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.5-3
    Available: vitalpbx-monitor-2.0.5-4.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.5-4
    Available: vitalpbx-monitor-2.0.5-5.x86_64 (vpbx)
    vitalpbx-monitor = 2.0.5-5
    Available: vitalpbx-monitor-2.1.0-2.x86_64 (vpbx)
    vitalpbx-monitor = 2.1.0-2
    You could try using –skip-broken to work around the problem
    ** Found 6 pre-existing rpmdb problem(s), ‘yum check’ output follows:
    vitalpbx-2.1.0-3.x86_64 is a duplicate with vitalpbx-2.1.0-1.x86_64
    vitalpbx-2.1.0-3.x86_64 has missing requires of vitalpbx-monitor = (‘0’, ‘2.1.0’, ‘3’)
    vitalpbx-asterisk-configs-2.1.0-3.x86_64 is a duplicate with vitalpbx-asterisk-configs-2.1.0-1.x86_64
    vitalpbx-sounds-2.1.0-3.x86_64 is a duplicate with vitalpbx-sounds-2.1.0-1.x86_64
    vitalpbx-sounds-es-2.1.0-3.x86_64 is a duplicate with vitalpbx-sounds-es-2.1.0-1.x86_64
    vitalpbx-themes-2.1.0-3.x86_64 is a duplicate with vitalpbx-themes-2.1.0-1.x86_64

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies

    You have a dirty installation, you should reinstall VitalPBX. You can remove vitalpbx and reinstall in the following way:

    yum remove vitalpbx*

    yum install vitalpbx
    0
    Tassos
    Participant

    That did not work

    [root@dispan-vitalpbx ~]# yum remove vitalpbx*
    Loaded plugins: fastestmirror
    No Match for argument: vitalpbx-2.1.0-1.x86_64.rpm
    No Match for argument: vitalpbx-monitor-2.1.0-1.x86_64.rpm
    No Packages marked for removal

    0

    I believe this is the solution for this kind of errors, first install the yum utils package:

    yum install yum-utils

    then execute the following command: 

    yum-complete-transaction

    If the command above doesn’t work, then, try with the following command:

    package-cleanup --cleandupes
    0
    Tassos
    Participant

    The first two commands you suggested did not work.

    I did not use the third one as I had already reinstalled the whole thing.

    Thanks anyway.

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.