Problems configuring a callcentric trunk

VitalPBX Community Support General Discussion Problems configuring a callcentric trunk

Up
0
Down
  • Post
    Tom
    Participant

    Hi,

    I have a new vitalpbx running IncrediblePBX 2.3.8-1.

    I am having problems getting a callcrnteic trunk configured properly.

    It I am able to get it to register and I have a default route setup that points to one of the extension.

    In looking at sngrep it shows that the call is rejected 484 Address incomplete:

    204.11.192.36:5060 192.168.0.7:5060 │Via: SIP/2.0/UDP 204.11.192.36:5060;branch=z9hG4bK-50e019be3c22396df30a67b2f07f83ec;received=204
    ──────────┬───────── ──────────┬─────────│1.192.36;rport=5060
    │ INVITE (SDP) │ │From: <sip:1267XXXXXXX@66.193.176.35>;tag=3780234381-676787
    13:06:22.045113 │ ──────────────────────────> │ │To: <sip:1609XXXXXXX@ss.callcentric.com>;tag=as1e4fe827
    +0.002776 │ 484 Address Incomplete │ │Call-ID: 36100497-3780234381-676751@msw1.telengy.net
    13:06:22.047889 │ <────────────────────────── │ │CSeq: 1 INVITE
    +0.057477 │ ACK │ │Server: VitalPBX
    13:06:22.105366 │ ──────────────────────────> │ │Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
    +4.079792 │ ACK │ │Supported: replaces, timer
    13:06:26.185158 │ ──────────────────────────> │ │Content-Length: 0

    My trunk config is as follows:

    videosupport=no
    type=peer
    secret=MY_SECRET
    insecure=port,invite
    host=callcentric.com
    fromuser=1777XXXXXXX101
    fromdomain=callcentric.com
    disallowed_methods=UPDATE
    disallow=all
    directmedia=no
    defaultuser=1777XXXXXXX101
    allow=ulaw

    The register string looks as follows:

    1777XXXXXXX101:MY_SECRET@callcentric.com

    The trunk registers with callcentric and a sip show peers shows it is connected to callcentric

    Can someone give me an idea what I am missing?

    Regards,

    Tom

     

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • Replies

    Are you testing outgoing or incoming calls? 

    0
    Tom
    Participant

    Incoming Calls so far.

    I have successfully placed outgoing calls through another provider but have tried with the callcentric trunk.

    0

    Try adding your DID at the end of the register string:

    1777XXXXXXX101:MY_SECRET@callcentric.com/YOUR_DID

    0
    Tom
    Participant

    Hi mrivera,

     

    Thanks for the quick response. That worked. I never would have figured that out without your help.

    So if I have more than 1 did from that provider do I need to create a different trunk for each did?

    This just seems weird. I did not need that with freepbx. Is this a vitalpbx thing or callcentric weirdness?

    Regards,

    Tom

    0

    I think this is something related to call centric, maybe, because we use the latest asterisk versions.

    We have a telnyx trunk with multiple DIDs and we don’t have to provide the DID at the end of the register string, and all the DIDs work well with the same trunk.

    0
    Tom
    Participant

    Hi,

     

    It looks like this is a callcentric thing. In doing a little more research I found the following in the freepbx dialplan:

    ;——————————————————————————-
    ; from-pstn-to-did:
    ;
    ; The context is designed for providers who send the DID in the TO: SIP header
    ; only. The format of this header is:
    ;
    ; To: <sip:2125551212@172.31.74.25>
    ;
    ; So the DID must be extracted between the sip: and the @, which this does
    ;
    [from-pstn-toheader]
    exten => _.,1,NoOp(Attempting to extract DID from SIP To header)
    exten => _.,n,gotoif($[“${CHANNEL(channeltype)}”=”SIP”]?SIP)
    exten => _.,n,gotoif($[“${CHANNEL(channeltype)}”=”PJSIP”]?PJSIP)
    exten => _.,n,NoOp(Unable to determine SIP channel type)
    exten => _.,n,goto(from-pstn,${EXTEN},1))
    exten => _.,n(SIP),Goto(from-pstn,${CUT(CUT(SIP_HEADER(To),@,1),:,2)},1)
    exten => _.,n(PJSIP),Goto(from-pstn,${CUT(CUT(PJSIP_HEADER(read,To),@,1),:,2)},1)

    ;——————————————————————————-

    It appears that this is what callcentric does. In free pbx I simply add “context=from-pstn-toheader” to the trunk configuration and all is well.

    What is the correct way to achieve something like this with vitalpbx?

    Regards,

     

    Tom

    0

    On VitalPBX, on the latest versions, the trunks has a field labeled “Get DID From”, so, you may set this parameter to the value “To”.

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.