Reister ok, call no singnal and audio

VitalPBX Community Support General Discussion Reister ok, call no singnal and audio

Up
0
Down
  • Post
    vtminh2006
    Participant

    Hi all,

    I setup 2 test system.

    1. PBX server and client is local network –> everything is ok.

    2. PBX server in datacenter (public ip, no NAT), 2 client in orther network

    VitalPBX(IP WAN) <–internet–>(IP WAN)Router(IP LAN) <–192.168.5.0/24 network–>Client

    No audio, log system:

    [2020-01-16 16:24:24] VERBOSE[1888][C-00000017] netsock2.c: Using SIP RTP TOS bits 184
    [2020-01-16 16:24:24] VERBOSE[1888][C-00000017] netsock2.c: Using SIP RTP CoS mark 5
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [102@hot-desking-context:1] Set(“SIP/101-00000015“, “CDR(source)=101“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [102@hot-desking-context:2] Set(“SIP/101-00000015“, “CDR(destination)=102“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [102@hot-desking-context:3] NoOp(“SIP/101-00000015“, “Hot Desking“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [102@hot-desking-context:4] Set(“SIP/101-00000015“, “__TENANT=9314c285c6380105“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [102@hot-desking-context:5] Gosub(“SIP/101-00000015“, “sub-hot-desking-call,s,1(102)“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-hot-desking-call:1] NoOp(“SIP/101-00000015“, “Trying to connect call“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-hot-desking-call:2] Set(“SIP/101-00000015“, “EXTENSION=102“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-hot-desking-call:3] Gosub(“SIP/101-00000015“, “sub-get-device-tree,s,1“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:1] NoOp(“SIP/101-00000015“, “Configuring Device Tree“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:2] Set(“SIP/101-00000015“, “DEV_TECHNOLOGY=SIP“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:3] GosubIf(“SIP/101-00000015“, “0?s-local,1“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:4] GotoIf(“SIP/101-00000015“, “0?return“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:5] GotoIf(“SIP/101-00000015“, “0?pjsip“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:6] GotoIf(“SIP/101-00000015“, “0?:digital“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx_builtins.c: Goto (sub-get-device-tree,s,12)
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:12] Set(“SIP/101-00000015“, “DEV_USER=101“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:13] Set(“SIP/101-00000015“, “INTERFACE=SIP/101“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:14] Set(“SIP/101-00000015“, “DEV_TREE=devices/SIP/101“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-get-device-tree:15] Return(“SIP/101-00000015“, “”) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-hot-desking-call:4] Set(“SIP/101-00000015“, “ASSIGNED_EXTEN=“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [s@sub-hot-desking-call:5] GotoIf(“SIP/101-00000015“, “1?no_exten_assigned,1“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx_builtins.c: Goto (sub-hot-desking-call,no_exten_assigned,1)
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [no_exten_assigned@sub-hot-desking-call:1] NoOp(“SIP/101-00000015“, “This device don’t have any extension assigned“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [no_exten_assigned@sub-hot-desking-call:2] GotoIf(“SIP/101-00000015“, “0?emergency-calls,102,1“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] pbx.c: Executing [no_exten_assigned@sub-hot-desking-call:3] Playback(“SIP/101-00000015“, “sorry-cant-let-you-do-that&goodbye“) in new stack
    [2020-01-16 16:24:24] VERBOSE[9765][C-00000017] file.c: <SIP/101-00000015> Playing ‘sorry-cant-let-you-do-that.ulaw’ (language ‘en’)
    [2020-01-16 16:24:27] VERBOSE[9765][C-00000017] file.c: <SIP/101-00000015> Playing ‘goodbye.ulaw’ (language ‘en’)
    [2020-01-16 16:24:28] VERBOSE[9765][C-00000017] pbx.c: Executing [no_exten_assigned@sub-hot-desking-call:4] Hangup(“SIP/101-00000015“, “”) in new stack
    [2020-01-16 16:24:28] VERBOSE[9765][C-00000017] pbx.c: Spawn extension (sub-hot-desking-call, no_exten_assigned, 4) exited non-zero on ‘SIP/101-00000015’

     

    Thanks.

    0
Viewing 1 replies (of 1 total)
  • Replies
    hlev
    Participant

    @vtminh2006 Audio issues like that are normally caused due to NAT problems. You can either change the NAT config per affected extension that is using the Remote PBX, by modifying the SIP devices NAT option to FORCE, COMEDIA or go into the global SIP Settings and set the NAT option there.

    Either of those should make your extensions properly register to the PBX and get audio without issues.

    0
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.