RTP While Recording

VitalPBX Community Support General Discussion RTP While Recording

Up
-1
Down
  • Post
    Up
    -1
    Down
    PitzKey
    Participant
    US

    Hi everyone,

    We recently came across a hair pulling situation where one of our PBXs stopped sending RTP as soon as it started recording voicemails and eventually terminated the call after 30 seconds, but it only happened when we called from a PBX in the same DataCenter. 

    No NAT issues, no Direct RTP, we’ve gone through the basic and advanced troubleshooting with no luck.

    Until we found this: https://github.com/asterisk/asterisk/blob/master/configs/samples/asterisk.conf.sample#L60

    We added it under SIP Settings > Custom, restarted Asterisk and it started sending RTP.

    You can see the setting if it is enabled or disabled by running ‘core show settings’

    So I hope someone who is in the same boat as us won’t have to go through the pain we went through, and finds this post easily..

    Perhaps the VitalPBX Team can make this the default, I see other major Asterisk re-compilers also have this enabled by default.

    Thank you

    1
Viewing 9 replies - 1 through 9 (of 9 total)
  • Replies
    TELECOMIN
    Participant

    Just would like to take feedback that after making changes to transmit_silence=yes how is recording and calls working since.

    Anything you would like to add?

    0
    PitzKey
    Participant
    US

    UPDATE: After looking at this, adding these parameters in the GUI does not even work, because it adds it under the [general] settings in /etc/asterisk/ombutel/sip__10-general.conf

    It needs to be added under [options].

    I found under /etc/asterisk/ombutel/asterisk__20-maxfiles.conf:

    [options](+)
    maxfiles = 20000

    So I manually added:

    transmit_silence=yes

    And I restarted Asterisk.

    1) Is it possible to add these from the GUI?

    2) Is it possible to have this be the default?

    Thanks

    1

    I think this parameter doesn’t come by default because it is not used often. it’s a very particular situation what is happening to you

    0
    PitzKey
    Participant
    US
    Tried posting here a follow up, it does not show up 😥
    0
    PitzKey
    Participant
    US
    I initially posted my issue on the official Asterisk Forum.

    Joshua Colp (Asterisk Technical Lead) responded with the below:

    There is an explicit option required to send silence when recording

    https://github.com/asterisk/asterisk/blob/master/configs/samples/asterisk.conf.sample#L60

    And when asked is there’s a difference between transmit_silence and transmit_silence_during_record? He said:

    There is no difference, they are the same. If I recall correctly the option was expanded to cover sending silence during more scenarios so it became transmit_silence.

     

    So I do think this should be the default and it will help other users, or at least it won’t cause any harm.

    Thank you

    0
    DonniLiem
    Participant
    Hi..while searching the solution for my issue i found an answer on a thread. I made the StreamType “live”, and use the MediaCasterStreamManager to start a stream with rtp-record. Then tried playing the stream in the SimpleVideoStreaming example. I was able to view the live stream while it is recording.
    0
    PitzKey
    Participant
    US
    Hi sir, can you please elaborate?
    0
    mo10
    Participant
    I have the same problem after 30 seconds. I will check if this helps. Thanks.
    0
    mo10
    Participant
    THANK YOU Pitzkey, works like a charm.
    I bet many poeple have this problem and might not notice right away.
    My provider hangs up after 30 seconds of silence otherwise.
    • This reply was modified 1 month, 4 weeks ago by mo10.
    0
Viewing 9 replies - 1 through 9 (of 9 total)

Tagged: ,

  • You must be logged in to reply to this topic.