Sangoma FXO card and Wanpipe installation for VitalPBX

VitalPBX Community Support General Discussion Sangoma FXO card and Wanpipe installation for VitalPBX

Up
0
Down
  • Post
    hguo83
    Participant
    I have just installed VitalPBX and it can't detect my Sangoma FXO card when i use Settings --> Telephony --> Interfaces --> Detect Hardware in the web-gui

    But in cli, i can see the following :

    # dahdi_hardware
    pci:0000:04:00.0 wanpipe- 1923:0040 Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card

    # lspci -v
    04:00.0 Network controller: Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card
    Subsystem: NEC Corporation Device 1300
    Flags: bus master, medium devsel, latency 64, IRQ 11
    Memory at f7d00000 (32-bit, non-prefetchable)

    # dahdi_scan
    no output

    [root@vitalpbx ~]# systemctl status dahdi
    ● dahdi.service - LSB: DAHDI kernel modules
    Loaded: loaded (/etc/rc.d/init.d/dahdi; bad; vendor preset: disabled)
    Active: active (exited) since Wed 2018-03-07 20:24:08 +08; 40min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 880 ExecStart=/etc/rc.d/init.d/dahdi start (code=exited, status=0/SUCCESS)

    Mar 07 20:24:08 vitalpbx.local systemd[1]: Starting LSB: DAHDI kernel modules…
    Mar 07 20:24:08 vitalpbx.local dahdi[880]: Loading DAHDI hardware modules:
    Mar 07 20:24:08 vitalpbx.local dahdi[880]: wanpipe: modprobe: FATAL: Module wanpipe not found.
    Mar 07 20:24:08 vitalpbx.local dahdi[880]: [FAILED]
    Mar 07 20:24:08 vitalpbx.local dahdi[880]: using ‘/etc/dahdi/assigned-spans.conf’
    Mar 07 20:24:08 vitalpbx.local dahdi[880]: Running dahdi_cfg: [ OK ]
    Mar 07 20:24:08 vitalpbx.local systemd[1]: Started LSB: DAHDI kernel modules.

    How do i install wanpipe for dahdi in VitalPBX ? I had tried to followed this guide here : https://striker24x7.blogspot.sg/2013/06/how-to-reinstall-or-uninstall-or.html
    but i kept getting stuck at this step below :

    Looking for zaptel/dahdi directory in /usr/src …
    ——————————————-

    No zaptel/dahdi dirs found in /usr/src
    Please use option “m” to enter zaptel/dahdi path

    ——————————————
    ——————————————
    m : Enter zaptel path manually

    (ctrl-c to Exit)
    Please select working zaptel directory [1-0][m]:






    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • Replies

    Currently we don’t have support for Sangoma Dahdi cards, but maybe in future versions we may add those kind of cards to VPBX

    0
    lazaro.baca
    Participant

    Hello

     

    I have a lot of elastix installations with sangoma cards, Is planned in some release to have support for that brand?

    0

    lazaro.baca We already tried to integrate them, but, without success, if you have kind of manual with the steps to make this cards work with vitalpbx, please let us know

    0
    lazaro.baca
    Participant

    Please put the libpri src rpm in the downloads, there is neccesary for trying to conmpile the sangoma package

    0

    lazaro.baca is done!!

    0
    lazaro.baca
    Participant

    Hello, I dont know how to generate a rpm file, i have the wanpipe src modified and I think there is no errors compiling, how can I generate the rpm? the spec that come with the src giveme errors

    0

    lazaro.baca, check this post:

    0
    lazaro.baca
    Participant

    Excelent! I’ll test them, thanks!

     

    0
    sayso
    Participant

    Hi. I created the wanpipe rpm’s for in house use and over the years they have been successfully adapted to a number of systems (centos 4,5,6,7 etc). Once installed you should run setup_dahdi to configure the card. That should be it. Hope it works for you like it does me! Let me know if not. Thanks

    0
    lazaro.baca
    Participant

    I think there is a lot of changes to do in web app because I think this is not prepared for configure sangoma cards, there give me a lot of errors when I try to detect hardware

    0

    Lazaro, for us the importance of this test is verify that the packages are builded in the right way,. and is possible to detect the sangoma cards, at least from the CLI

    0
    sayso
    Participant

    You will need to login as root and run “wancfg_dahdi” to configure the card. It will show up as Dahdi channels after that … after configuration, run “dahdi_cfg -v” to see the channels.

    0
    lazaro.baca
    Participant

    Yes, I just say that if setup-sangoma will be as part of the package, should be modified, or in another case, eliminated from the source package ? 

    0
    lazaro.baca
    Participant

    My sangoma card was correctly detected ?  ? 

    0
    sayso
    Participant

    Funny. I never paid attention to setup-sangoma as the sangoma docs I read (back in the day) just mentioned running wancfg_{zaptel,dahdi}… I think it should be easy enough to update it to detect distributions or, to make it easy, just eliminate it! lol

    Lazaro! Glad it is detected! should be the hard part is over now.

    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.