Setting Up Grandstream GXW4216 Analog Gateway

VitalPBX Community Support General Discussion Setting Up Grandstream GXW4216 Analog Gateway

  • Post
    technomancer_101
    Participant
    Up
    -1
    Down

    Hey there,

    I am trying to get my GXW4216 setup so I can support a few analog extensions (1 fax machine), but I cannot for the life of me figure out what I’m missing.

    I believe I have the gateway configured, but I cannot get my extensions to register on the PBX. Is there a specific setting I have to set to allow the gateway to talk to the PBX?

    Thanks

    0
Viewing 6 replies - 1 through 6 (of 6 total)
  • Replies
    Up
    0
    Down

    You may create one trunk per phone line or create one trunk for all the phone lines.

    Your trunk (On VitalPBX side) should have the following information on the Outgoing section:

    type=friend
    qualify=yes
    secret=password
    host=YOUR-GXW-IP
    port=5060
    dtmfmode=rfc2833
    canreinvite=no
    disallow=all
    allow=ulaw
    insecure=port,invite

    Make sure your GXW has an static IP, and the lines profile have the SIP Registration parameter in “No”

    0
    technomancer_101
    Participant
    Up
    0
    Down

    Okay, trunk is up and running. So, if I’m setting SIP registration to “No”, does that mean I should define the extensions on the GXW, but not under extensions on VitalPBX?

    0
    Up
    0
    Down

    Yes, the extensions should only be defined on the Gateway due is connected through trunk

    0
    technomancer_101
    Participant
    Up
    0
    Down

    Okay, starting to get somewhere. Now when I dial to the trunk, it routes automatically to port 1, may have to make a hunt group for it to work properly.

    Is there no way to configure VitalPBX so I can register the extensions without the use of a trunk?

     

    0
    Up
    0
    Down

    Yes, you can use extensions instead of trunks, just enable the SIP registration and setup the FXS information and credentials on the GXW side.

    0
    technomancer_101
    Participant
    Up
    0
    Down

    Got it up and running. There appears to be a bug with applying settings on the GXW side of things. Everything is registering properly now.

    Thanks!

    0
Viewing 6 replies - 1 through 6 (of 6 total)

Tagged: ,

  • The topic ‘Setting Up Grandstream GXW4216 Analog Gateway’ is closed to new replies.