SIP clients unable to connect

VitalPBX Community Support General Discussion SIP clients unable to connect

  • Post
    michal
    Participant

    I’m not exactly sure with which version this happened but none of my SIP clients are able to connect to the extensions that have been created for them. In fact the SIP port on the VitalPBX server seems to be closed.

    PORT     STATE  SERVICE

    5060/tcp closed sip

     

     

    0
Viewing 8 replies - 16 through 23 (of 23 total)
  • Replies
    Up
    0
    Down

    What’s the output of the following command:

    grep -i chan_sip /var/log/asterisk/full
    0
    michal
    Participant
    Up
    0
    Down

    There are a lot of the 2 peers I have reconnecting. If I look back far enough I see the 70x SIP clients registering too. No failures of the 70x or 9000 extensions recently. Here’s the last time they were reachable:

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘703′ is now Reachable. (393ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘708′ is now Reachable. (410ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘704′ is now Reachable. (412ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘706′ is now Reachable. (422ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘701′ is now Reachable. (435ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘702′ is now Reachable. (440ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘707′ is now Reachable. (452ms / 2000ms)

    [2018-07-19 06:54:36] NOTICE[1948] chan_sip.c: Peer ‘705′ is now Reachable. (456ms / 2000ms)

    They become UNREACHABLE about 5 hours later and never came back.

    0
    Up
    0
    Down

    There is not reason for your issue, this has nothing to do with the update, due any other user hasn’t reported that behavior

    0
    michal
    Participant
    Up
    0
    Down

    I don’t really know where to go from here.. Does this tell us anything?

    Fortress:~ michal$ sudo sipsak -vv -s sip:9000@vitalpbx

     

    using A record: vitalpbx

     

    message received:

    SIP/2.0 200 OK

    Via: SIP/2.0/UDP 192.168.1.231:57493;branch=z9hG4bK.7c173434;alias;received=192.168.1.231;rport=57493

    From: sip:sipsak@192.168.1.231:57493;tag=5a8a8ad8

    To: sip:9000@vitalpbx;tag=as15d019d9

    Call-ID: 1519028952@192.168.1.231

    CSeq: 1 OPTIONS

    Server: VitalPBX

    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE

    Supported: replaces, timer

    Contact: <sip:192.168.1.185:5060>

    Accept: application/sdp

    Content-Length: 0

     

     

     

    ** reply received after 0.704 ms **

       SIP/2.0 200 OK

       final received

    Fortress:~ michal$ sudo sipsak -vv -s sip:701@vitalpbx

    using A record: vitalpbx

     

    message received:

    SIP/2.0 200 OK

    Via: SIP/2.0/UDP 192.168.1.231:61067;branch=z9hG4bK.438d56fd;alias;received=192.168.1.231;rport=61067

    From: sip:sipsak@192.168.1.231:61067;tag=5a98b3af

    To: sip:701@vitalpbx;tag=as2625047f

    Call-ID: 1519956911@192.168.1.231

    CSeq: 1 OPTIONS

    Server: VitalPBX

    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE

    Supported: replaces, timer

    Contact: <sip:192.168.1.185:5060>

    Accept: application/sdp

    Content-Length: 0

     

     

     

    ** reply received after 0.859 ms **

       SIP/2.0 200 OK

       final received

     

    0
    Up
    0
    Down

    Send me a full backup of your system to try to emulate your environment.

    miguel@vitalpbx.com

    0
    michal
    Participant
    Up
    0
    Down

    Sent (about 10 hours ago).

    0
    Up
    0
    Down

    We will start to make the tests with your backup

    0
    Up
    0
    Down

    I install the latest version of VitalPBX, then I upload de backup to my new server and after make all the required test, it was imposible to reproduce the issue. I registered two extensions, the extension 9000 and the extension 708 both with X-lite, and all was ok.

    Conclusion: The issue you are reporting doesn’t have relation with VitalPBX or Asterisk, this something with your network. If you are using a dynamic network, I suggest to change to an static one. Check with the command “ip a” if you are pointing to the right IP address.

    0
Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.