Sonata Stats 1.0.1-3: custom logo lost, plot outside left side

VitalPBX Community Support Reporting an Issue Sonata Stats 1.0.1-3: custom logo lost, plot outside left side

  • Post
    giovanni.v
    Participant
    IT
    I tried to upload a custom “company logo” (Settings -> Report settings), the custom image load, show up on the settings page and seem to save without problems. But…
    1) Accessing the setting page again shows “Error getting the image” and a refresh icon instead of the image; sometimes this happen only after a logout/login. Tried both jpg and png formats.
    2) The custom image is never printed on pdf reports.

    Also when printing a pdf report from Traffic->By Hour the graph the start time on X axis is put outside the left margin, please see the attached image.

    Attachments:
    You must be logged in to view attached files.
    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • Replies
    Roger Gaitan
    Participant
    none
    Up
    0
    Down
    Hello,

    We’ll take a look about the miss aligned graph in the pdf export, as for the image upload issue we found a problem with one of the folders where the images are uploaded you can try this work around:

    • Delete the folder /usr/share/sonata/queues-stats/backend/public/storage
    • and then execute the following php /usr/share/sonata/queues-stats/backend/artisan storage:link

    This will be fixed in the next update thanks again for your feedback.

     

    0
    giovanni.v
    Participant
    IT
    Up
    0
    Down
    I not found the mentioned storage forder (a symlink, really) so I executed the script and that created it.

    [root@ipbx ~]# ls -al /usr/share/sonata/queues-stats/backend/public/storage
    ls: cannot access /usr/share/sonata/queues-stats/backend/public/storage: No such file or directory

    [root@ipbx ~]# php /usr/share/sonata/queues-stats/backend/artisan storage:link
    The [public/storage] directory has been linked.

    [root@ipbx ~]# ls -al /usr/share/sonata/queues-stats/backend/public/storage
    lrwxrwxrwx 1 root root 57 Nov 19 19:40 /usr/share/sonata/queues-stats/backend/public/storage -> /usr/share/sonata/queues-stats/backend/storage/app/public
    [root@ipbx ~]# ls -al /usr/share/sonata/queues-stats/backend/public/storage/
    total 12
    drwxrwxr-x 3 apache apache 4096 Aug 16 20:22 .
    drwxrwxr-x 3 apache apache 4096 Aug 16 20:22 ..
    drwxrwxr-x 2 apache apache 4096 Nov 19 19:44 images
    [root@ipbx ~]# ls -al /usr/share/sonata/queues-stats/backend/public/storage/images/
    total 20
    drwxrwxr-x 2 apache apache 4096 Nov 19 19:44 .
    drwxrwxr-x 3 apache apache 4096 Aug 16 20:22 ..
    -rw-r--r-- 1 apache apache 8814 Nov 19 19:44 t6RGmIESjdt8vCiWt3ip1q6yzH7s4tp5guFRlFkG.png

    That way the image appeared in settings, however I changed it and checked again… still here. Ok.

    But at printing any report the left top area where the image is expected to be is still blank. Before uploading an image the very first time the default image was printed on pdf reports.

    Now at version 1.0.1-4, the left graph overflow seem disappeared.

    0
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.