Sonata Switchboard and SSL

VitalPBX Community Support General Discussion Sonata Switchboard and SSL

Up
0
Down
  • Post
    Matthew Topping
    Participant

    Hello,

     

    I am experiencing an issue with the Switchboard when using SSL. I can log in, but right after that the switchboard goes to “connecting to server”. If I use the regular http login it works. Please note that I’ve forced SSL. . I see the API reference to HTTP. I also can not build a connection. If I disable force HTTPS it works by simply changing  the url to  http://****/sonata/switchboard. I also found that when using “force https” I can not establish an API connection from the switchboard.

     

    This is in /var/log/httpd/*

    ==> /var/log/httpd/access_log <==
    127.0.0.1 – – [04/Sep/2018:09:26:25 +0800] “POST /api/authenticate HTTP/1.1” 301 242 “-” “-“

    ==> /var/log/httpd/error_log <==
    [Tue Sep 04 09:26:25.414441 2018] [:error] [pid 17335] [client 203.177.174.249:50426] PHP Notice: Trying to get property of non-object in /usr/share/sonata/switchboard/www/core/components/pbx/Ombutel.php on line 0, referer: https://******/sonata/switchboard/

    ==> /var/log/httpd/access_log <==
    127.0.0.1 – – [04/Sep/2018:09:26:25 +0800] “POST /api/authenticate HTTP/1.1” 301 242 “-” “-“

    ==> /var/log/httpd/error_log <==
    [Tue Sep 04 09:26:25.506816 2018] [:error] [pid 17335] [client 203.177.174.249:50426] PHP Notice: Trying to get property of non-object in /usr/share/sonata/switchboard/www/core/components/pbx/Ombutel.php on line 0, referer: https://*****/sonata/switchboard/

    ==> /var/log/httpd/access_log <==
    203.177.174.249 – – [04/Sep/2018:09:26:25 +0800] “POST /sonata/switchboard/ HTTP/1.1” 200 7104 “https://*******/sonata/switchboard/&#8221; “Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0”

     

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • Replies

    Are you using self signed certificate?

    What version of Sonata Switchboard are you using?

    0
    Matthew Topping
    Participant

    I am using a Lets encrypt cert.

     

    rpm -qa | grep -i switch
    sonata-switchboard-2.0.2-1.x86_64

    0

    Try copying the certificates configurations from this file: /usr/share/ombutel/monitor/config.ini to this /usr/share/sonata/switchboard/monitor/config.ini

    Only copy the certificates configurations (keyFile, certFile, caFile), don’t edit any other setting.

    0
    Matthew Topping
    Participant

    Hey mate, I started to look at the console in my browser, and found that the switchboard connects over 3008 using ssl, 3001 for normal http. I have not touched my certs, but I did add in a rule for 3008 for the switchboard, and now it works. Thanks for the replies!

    0
    Matthew Topping
    Participant

    errr, or maybe I did do something else. I just copied the lines from /usr/share/ombutel/monitor/config.ini to /usr/share/sonata/switchboard/monitor/config.ini and that worked also. Once again, thanks for the awesome support.

    0
    kbohannon
    Participant

    What was the solution for this issue in the end? With a fresh install of VPBX 2.3 and Sonata Switchboard, I still am unable to connect to the database unless “Force HTTPS” is disabled. I have tried both of the steps above, but to no avail.

    0
    InTeleSync
    Participant

    For me, disabled Force HTTPS. Refreshed the Switchboard and all came up. Went back and enabled Force HTTPS. Refreshed the Switchboard and it stayed up. For giggles rebooted the server, and tried the Switchboard again and all appears to be well now.

    Using a Positive SSL wildcard cert.

     

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.