Sonata Switchboard Over HTTPS

VitalPBX Community Support General Discussion Sonata Switchboard Over HTTPS

  • Post
    minda
    Participant

    Brand new install. Created new user. Log in as that user. Up in a top I click to dial a number and I am getting error Connecting To Server… And nothing happens.

    I deleted that user as it was as a tenant. Created user on Vital PBX. Assigned user in Sonata Switchboard. Logged in. Again anything I do I get that error. 

    Administration – Connection – shows connected.

    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • Replies
    Up
    0
    Down

    Are you using https?

    0
    minda
    Participant
    Up
    0
    Down

    yes I am. Let’s Encrypt. The one that you can configure in PBX.

    0
    Up
    0
    Down

    On VitalPBX go to the firewall module (Admin / Security / Firewall), on the services tab, add a service as shown in the picture attached

    0
    Up
    0
    Down

    On same module, but in the rules tab add a new rule as shown in the picture attached 

    0
    minda
    Participant
    Up
    0
    Down

    Thanks! It works now. But this rule should be added automatically one you enable HTTPS. I do you suppose to figure this out yourself why you were getting error?

    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.