TLS Support

Up
0
Down
  • Post
    TheG-Man
    Participant

    Greetings!

    I’m looking for instruction on how to add TLS to VitalPBX. Do you guys have anything you can share?

    Best Regards,

    -G

    0
Viewing 15 replies - 1 through 15 (of 15 total)
  • Replies

    You can enable TLS support in the SIP Settings module

    0
    TheG-Man
    Participant

    Thanks. Does the cert needs to be in specific location to be picked up by web gui?

    0

    The cerst must be generate by the Certificates module of VitalPBX, by know only self signed are working for TLS calls.

    0

    The cerst must be generate by the Certificates module of VitalPBX, by know only self signed are working for TLS calls.

    0
    TheG-Man
    Participant

    That works.

    Thanks!

    0
    TheG-Man
    Participant

    I have an asterisk proxy and I’m trying to create TLS trunk between VitalPBX and asterisk but it doesn’t work. I can register phone to asterisk without any issues. 

    Attached is screenshot with config.

    0
    TheG-Man
    Participant

    And here is Advanced tab for trunk.

    0

    You must enable the TLS in the SIP Settings module, under Network Tab.

    Check this link: https://wiki.asterisk.org/wiki/display/AST/SIP+TLS+Transport

    0
    TheG-Man
    Participant

    Here is what I got there.

    0

    Create a self-signed certificate and assigned to the SIP Settings

    0
    TheG-Man
    Participant

    Did that, and it didn’t help. The thing is, VitalPBX is a client to Asterisk server, so I don’t know how certificate on VItalPBX should help.

    0

    According to asterisk documentation you must to define the certificate to use for secure calls

    0
    TheG-Man
    Participant

    I think, I’m getting closer. Now I get this error.

    chan_sip.c:17828 register_verify: ‘UDP’ is not a valid transport for ‘VitalPBX’. we only use ‘TLS’! ending call.

    I’m pretty sure I have transport type setup properly on VitalPBX.

    0
    TheG-Man
    Participant

    I think I got it. After long search I found that the registration string needs to start with tls:// otherwise it will use UDP to register.

    0
    I have try to configure TLS for the phone, account registered. Outgoing is ok, incoming problem for the phone configure TLS ? Why can help ?
    0
Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.