Transferring Queue Calls to an Extension with FollowMe

VitalPBX Community Support General Discussion Transferring Queue Calls to an Extension with FollowMe

  • Post
    PitzKey
    Participant
    US
    Up
    0
    Down
    Hello,

    VitalPBX 3.0.4-2

    When an agent answers a Queue call and then transfers it to an extension with FollowMe enabled, the PBX will first ring only the extension for 30 seconds and then it will start to ring the extension with FollowMe.

    This is happening on a Multi Tenant system as well as on a non Multi Tenant.

    Multi Tenant:

    9084441111 = DID
    9085552222 = CID
    4449996565 = FM Number

    Log: https://pastebin.com/kQm7vD83 (Raw: https://pastebin.com/raw/kQm7vD83)

    FollowMe Settings:

    Non Multi Tenant System:

    8459991234 DID
    8454448855 CID
    8453334545 FM Number

    Log: https://pastebin.com/vyDUvc8d (Raw: https://pastebin.com/raw/vyDUvc8d)

    Please let me know if you need anything further.

    Thanks

    0
Viewing 10 replies - 1 through 10 (of 10 total)
  • Replies
    PitzKey
    Participant
    US
    Up
    0
    Down
    Bump?
    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Does anyone see this post?

    This is still an issue on 3.0.4-4

    Thanks

    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Bump bump
    0
    Up
    0
    Down
    What is the issue here?
    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Normally, when you call an extension that has FollowMe enabled, it’ll ring the list of numbers specified in the FollowMe list.

    Here, it rings first the only extension for 30 seconds, and after 30 seconds it starts ringing the FollowMe list.

    Meaning, if you are at home and answering calls on your cellphone, your cellphone won’t get the call before 30 seconds which will obviously frustrate callers…

    0
    Up
    0
    Down
    What kind of transfer are you using?
    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Blind transfer
    0
    Up
    0
    Down
    Edit the base plan file (extensions__20-baseplan.conf) and under the context “sub-local-dialing”, change the following line:

    same => n,GotoIf($[$["${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/enable)}"="yes"]&$["${IGNORE_DIVERSIONS}"!="yes"]]?:check-rt)

    To

    same => n,GotoIf($[$[$["${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/enable)}"="yes"]&$["${IGNORE_DIVERSIONS}"!="yes"]]|$[$["${LEN(${BLINDTRANSFER})}"!="0"]&$["${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/enable)}"="yes"]]]?:check-rt)

    Let me know if this helps to fix what you’ve reported.

    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Hey,

    Thanks so much! I just tested this and it is working! I will let you know if we bump in to any issues.

    Thank you

    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Just a quick follow up @ing-joserivera26 this appears to be working fine. I hope this will be included in the next update!

    Thanks again!

    0
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.