Trunk Dial Out

  • Post
    voipnowpbx
    Participant
    Having issues with trunk

    [2020-11-01 14:45:31] ERROR[7683][C-00000020]: netsock2.c:303 ast_sockaddr_resolve: getaddrinfo(“telynx”, “(null)”, …): Name or service not known
    [2020-11-01 14:45:31] WARNING[7683][C-00000020]: chan_sip.c:6396 create_addr: No such host: telynx
    [2020-11-01 14:45:31] WARNING[7683][C-00000020]: app_dial.c:2576 dial_exec_full: Unable to create channel of type ‘SIP’ (cause 20 – Subscriber absent)

     

    This is what we get when trying to dial out. How do we fix this?

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • Replies
    voipnowpbx
    Participant
    Up
    0
    Down
    Ok, trunks are registered, however, calls fail to complete still from a remote device to the trunk.

    voipnowpbx*CLI> sip show peers
    Name/username Host Dyn Forcerport Comedia ACL Port Status Description
    2005/2005 74.132.252.108 D Yes Yes A 5060 OK (47 ms) Royce Mcknight
    voipnowpbx/voipnowpbx 104.248.56.89 Yes Yes 5060 OK (9 ms) VoIPNow PBX

    The above shows registrations, but, for some reason, outbound calls do not work

    0
    Up
    0
    Down
    Check the caller id that you are sending to the provider

    You can use sngrep to analyze the call flow, and check the response from the provider.

    0
    voipnowpbx
    Participant
    Up
    0
    Down
    The caller id shows properly. We also have no audio either direction. All ports required are opened as well. We have also disabled firewall, still, no audio either, nor is the trunk making it out to attempt provider.
    0
    voipnowpbx
    Participant
    Up
    0
    Down
    — (14 headers 0 lines) —
    Found peer ‘2005’ for ‘2005’ from 74.132.252.108:5060
    [2020-11-02 00:33:06] NOTICE[16310]: chan_sip.c:17499 check_auth: Correct auth, but based on stale nonce received from ‘”Royce Mcknight” <sip:2005@40.76.229.151:5060>;tag=1910169841’

    Please see above log when placing call

    0
    voipnowpbx
    Participant
    Up
    0
    Down
    Please see sngrep files attached.
    Attachments:
    You must be logged in to view attached files.
    0
    voipnowpbx
    Participant
    Up
    1
    Down
    It looks as if the local IP from pbx is showing rather than the public IP, How do we fix this?
    0
    voipnowpbx
    Participant
    Up
    0
    Down
    Here are the show sip settings:

    Global Settings:
    —————-
    UDP Bindaddress: 0.0.0.0:5060
    TCP SIP Bindaddress: 0.0.0.0:5060
    TLS SIP Bindaddress: 0.0.0.0:5061
    RTP Bindaddress: Disabled
    Videosupport: Yes
    Textsupport: No
    Ignore SDP sess. ver.: No
    AutoCreate Peer: Off
    Match Auth Username: No
    Allow unknown access: Yes
    Allow subscriptions: Yes
    Allow overlap dialing: Yes
    Allow promisc. redir: No
    Enable call counters: Yes
    SIP domain support: No
    Path support : No
    Realm. auth: No
    Our auth realm asterisk
    Use domains as realms: No
    Call to non-local dom.: Yes
    URI user is phone no: No
    Always auth rejects: Yes
    Direct RTP setup: No
    User Agent: VitalPBX
    SDP Session Name: Asterisk PBX 17.7.0
    SDP Owner Name: root
    Reg. context: (not set)
    Regexten on Qualify: No
    Trust RPID: No
    Send RPID: No
    Legacy userfield parse: No
    Send Diversion: Yes
    Caller ID: asterisk
    From: Domain:
    Record SIP history: Off
    Auth. Failure Events: Off
    T.38 support: No
    T.38 EC mode: Unknown
    T.38 MaxDtgrm: 4294967295
    SIP realtime: Disabled
    Qualify Freq : 60000 ms
    Q.850 Reason header: No
    Store SIP_CAUSE: No

    Network QoS Settings:
    —————————
    IP ToS SIP: CS3
    IP ToS RTP audio: EF
    IP ToS RTP video: AF41
    IP ToS RTP text: AF41
    802.1p CoS SIP: 3
    802.1p CoS RTP audio: 5
    802.1p CoS RTP video: 4
    802.1p CoS RTP text: 3
    Jitterbuffer enabled: No

    Network Settings:
    —————————
    SIP address remapping: Enabled using externhost
    Externhost: 40.76.229.151
    Externaddr: 40.76.229.151:0
    Externrefresh: 10
    Localnet: 10.0.3.0/255.255.255.0
    10.0.3.0/255.255.255.0

    Global Signalling Settings:
    —————————
    Codecs: (ulaw|alaw|g729)
    Relax DTMF: No
    RFC2833 Compensation: No
    Symmetric RTP: Yes
    Compact SIP headers: No
    RTP Keepalive: 0 (Disabled)
    RTP Timeout: 30
    RTP Hold Timeout: 300
    MWI NOTIFY mime type: application/simple-message-summary
    DNS SRV lookup: No
    Pedantic SIP support: Yes
    Reg. min duration 60 secs
    Reg. max duration: 3600 secs
    Reg. default duration: 120 secs
    Sub. min duration 60 secs
    Sub. max duration: 3600 secs
    Outbound reg. timeout: 20 secs
    Outbound reg. attempts: 0
    Outbound reg. retry 403:No
    Notify ringing state: Yes
    Include CID: Yes
    Notify hold state: No
    SIP Transfer mode: open
    Max Call Bitrate: 384 kbps
    Auto-Framing: No
    Outb. proxy: <not set>
    Session Timers: Accept
    Session Refresher: uas
    Session Expires: 1800 secs
    Session Min-SE: 90 secs
    Timer T1: 500
    Timer T1 minimum: 100
    Timer B: 32000
    No premature media: Yes
    Max forwards: 70

    Default Settings:
    —————–
    Allowed transports: UDP
    Outbound transport: UDP
    Context: sip-default
    Record on feature: one_touch_
    Record off feature: one_touch_
    Force rport: Yes
    DTMF: rfc2833
    Qualify: 0
    Keepalive: 0
    Use ClientCode: No
    Progress inband: No
    Language: en
    Tone zone: us
    MOH Interpret: default
    MOH Suggest:
    Voice Mail Extension: *97
    RTCP Multiplexing: No

    —-

    <— SIP read from UDP:74.132.252.108:5060 —>

    0
Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.