Update not working, fresh install not working

VitalPBX Community Support General Discussion Update not working, fresh install not working

  • Post
    Seb17
    Participant
    none
    Up
    0
    Down
    Hi,
    It seems there a little problem 🙂

    –> Finished Dependency Resolution
    Error: Package: vitalpbx-3.0.6-1.x86_64 (vpbx-core)
    Requires: glibc-common <= 2.17-317.el7
    Installed: glibc-common-2.17-322.el7_9.x86_64 (@updates)
    glibc-common = 2.17-322.el7_9
    Available: glibc-common-2.17-317.el7.x86_64 (base)
    glibc-common = 2.17-317.el7
    Error: Package: glibc-2.17-317.el7.i686 (base)
    Requires: glibc-common = 2.17-317.el7
    Installed: glibc-common-2.17-322.el7_9.x86_64 (@updates)
    glibc-common = 2.17-322.el7_9
    Available: glibc-common-2.17-317.el7.x86_64 (base)
    glibc-common = 2.17-317.el7
    Error: Package: vitalpbx-3.0.6-1.x86_64 (vpbx-core)
    Requires: glibc-headers <= 2.17-317.el7
    Installed: glibc-headers-2.17-322.el7_9.x86_64 (@updates)
    glibc-headers = 2.17-322.el7_9
    Available: glibc-headers-2.17-317.el7.x86_64 (base)
    glibc-headers = 2.17-317.el7
    Error: Package: glibc-devel-2.17-317.el7.i686 (base)
    Requires: glibc-headers = 2.17-317.el7
    Installed: glibc-headers-2.17-322.el7_9.x86_64 (@updates)
    glibc-headers = 2.17-322.el7_9
    Available: glibc-headers-2.17-317.el7.x86_64 (base)
    glibc-headers = 2.17-317.el7
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

    0
Viewing 5 replies - 1 through 5 (of 5 total)
  • Replies
    Rodrigo Cuadra
    Keymaster
    US
    Up
    0
    Down
    You need to downgrade glibc version 322, this version have a bug that affect the Asterisk dial plan.

    Go to console:

    # yum downgrade glibc-devel glibc glibc-common glibc-headers
    # systemctl restart asterisk

    0
    Seb17
    Participant
    none
    Up
    0
    Down
    thx, but not working…
    ./vps.sh is probably updating glibc so asterisk is not installed…

    So:

    ./vps.sh => dep error
    yum downgrade glibc-devel glibc glibc-common glibc-headers => ok
    ./vps.sh => dep error

    0
    Rodrigo Cuadra
    Keymaster
    US
    Up
    0
    Down
    We have already corrected the installation script for VPS, you can try again by downloading the new script.
    0
    Seb17
    Participant
    none
    Up
    0
    Down
    nope :/

    yum downgrade glibc-devel glibc glibc-common glibc-headers => ok
    Downloading packages:
    (1/4): glibc-2.17-317.el7.x86_64.rpm
    (2/4): glibc-devel-2.17-317.el7.x86_64.rpm
    (3/4): glibc-headers-2.17-317.el7.x86_64.rpm
    (4/4): glibc-common-2.17-317.el7.x86_64.rpm
    rm vps.sh => ok
    wget https://raw.githubusercontent.com/VitalPBX/VPS/vitalpbx-3/vps.sh => ok
    chmod +x vps.sh => ok
    ./vps.sh => same problem with glibc version

    Edit : remove yum -y update from script…

    • This reply was modified 5 months, 4 weeks ago by Seb17.
    0
    Rodrigo Cuadra
    Keymaster
    US
    Up
    0
    Down
    The new version of the Script contains the following line in yum update::

    yum update -x glibc, glibc-common, glibc-devel, glibc-headers

     

    Use this link for download the script:

    wget https://raw.githubusercontent.com/VitalPBX/VPS/master/vps.sh

     

    1
Viewing 5 replies - 1 through 5 (of 5 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.