Varius Tenants using a singre trunk for outbound

VitalPBX Community Support Frequently Asked Questions Varius Tenants using a singre trunk for outbound

Up
-1
Down
  • Post
    Up
    -1
    Down
    vitorcosta
    Participant

    Sorry if it already exists, I tryed to search in the forum and didnt found a tutorial about it.
    We have varius Tenants, each of them uses your own CID configured in the Outbound Round. All of them uses the same SIP Provider with identical configuration. Today, we are creating the “same” trunk inside each of the tenants (various identicals trunks).
    Since the trunk configuration is identical, is Is there a way to use a single Trunk so the outbound Route in the Tenant points to it?
    We must be able to inform a specific CID for each of the tenants.

    0
Viewing 10 replies - 1 through 10 (of 10 total)
  • Replies

    Yes, you can centralize all the configurations on the main tenant, then, create specific outbound routes for each tenants, then create route selection, and finally configure the tenants to use those routes selection, and the DID assigned to them.

    0
    vitorcosta
    Participant

    Perfect, we did it and its working fine for external numbers.
    But, can we simply give to a Tenant, access to a specific trunk in the main Vital?

    In the tenant options we can add other tenants in “Allowed Tenant Trunks”, but dont know what do do after that.
    We have two PBXs, that can call each other, and lots of tenants, each tenant having you own extension number and respective trunk for receiving an making calls, we’d love to use only one trunk for this, but with no need to create tons of outbound routes out of the tenant if possible.

    0

    @vitorcosta

    Yes, it is possible only to use one outbound route for all the tenants. You can configure just one trunk on the main system, then for the tenants you just assign the DIDs that belong to them and give them the outbound profiles to call through the main system’s outbound routes.

    You can create the Outbound profiles under PBX > Class of Service > Route Selection

    On the tenants, for outbound calls, you must assign the outbound profile to the classes of services you’ve created on the tenant.

     

     

    0
    Michael Olson
    Participant

    Sorry to revive an old thread, but I am having the same issue. 

    I created the Tenant, and gave it access to my routes:

    https://imgur.com/a/07LmfQe

    but, I don’t see it available on the COS for the Tenant:

    https://imgur.com/a/Y80XLdu

    0
    vividtelecom
    Participant
    Hi,

    Im currently struggling with this as well.

     

    Any ideas

    0
    Joseph Montes
    Keymaster
    US
    0
    First, on the tenant’s creation, you only need to define the outbound profile, then, you can log in, or switch to your new tenant, go to the Class of Service module, here, you will notice a new field named “Outbound Profile”.

    Just to clarify the steps:

    • On the main tenant, you will define the following items
      • Trunk
      • Outbound Routes
      • Route Selections
    • Then, you can create a new tenant, or modify an existing one. Here, on the calls routing tab, you must select your outbound profiles (Route Selections) that will be assigned to the tenant.
    • Finally, you must log in, or switch to your new tenant, and then, go to the Class of Service module and select the existing class of service, by default “All Permissions”. Here, you must update the outbound profile field with the desired option.

    Hope this helps

    0
    vividtelecom
    Participant
    Hi,

    I have followed the instructions however when i dial it doesnt ring? “Your call cannot be completed as dialled”.

    0
    Joseph Montes
    Keymaster
    US
    Hi, I have followed the instructions however when i dial it doesnt ring? “Your call cannot be completed as dialled”.

     

    Make sure that you can use that same route from the main system. This is to check if the route is done correctly. For testing you can narrow down your system’s routes to just one, and check that there are no other conflicting routes using the same dial patterns. If you can use that same single route on the main system, you can use it as an outbound profile.

    0
    Make sure you applied changes on your tenant, and on the main tenant. Also, make sure you are able to dial the numbers you are trying to dial on your tenant from the main tenant.
    0
Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.