Vitalpbx does not recognize, find or see DIGIUM TDM400P FXO/FXS card

VitalPBX Community Support General Discussion Vitalpbx does not recognize, find or see DIGIUM TDM400P FXO/FXS card

  • Post
    litebit
    Participant
    Hi,

    My setup :

    • an older HP desktop : CPU Intel(R) Core(TM)2 Duo CPU E6400 @ 2.13GHz, 2 GB RAM, 140GB HDD, 2x GB Network cards
    • a DIGIUM TDM400P card with 1 FXO and 1 FXS module (http://www.digiumcards.com/tdm400p.html)
    • CentOS 7 64bit install : CentOS Linux release 7.8.2003 (Core)
    • Kernel 3.10.0-1127.19.1.el7.x86_64
    • Asterisk 16.11.1
    • VitalPBX 2.4.2-7
    • VitalPBX installed via vps script

    The setup ran fine, no visible errors. After the final reboot, password set at first login.

    All services are running :

    Firewall OK
    Intrusion Detection OK
    Asterisk OK
    DAHDI OK

    The problem : the FXS/FXO hardware is not discovered.

    When I’m in the “Interfaces” screen, I click “detect hardware” and refresh the screen, but nothing gets discovered.

    Via CLI I can see this :

    # dahdi_hardware
    pci:0000:07:09.0 wctdm- e159:0001 Wildcard TDM400P REV I

    # lspci -v

    07:09.0 Network controller: Tiger Jet Network Inc. Tiger3XX Modem/ISDN interface
    Subsystem: Device b119:0001
    Flags: bus master, medium devsel, latency 32, IRQ 11
    I/O ports at 1100
    Memory at f0840000 (32-bit, non-prefetchable)
    Capabilities: [40] Power Management version 2
    Kernel modules: netjet, hisax

     

    # dahdi_scan
    Unable to open /dev/dahdi/ctl: No such file or directory

    # usr/sbin/dahdi_cfg
    Notice: Configuration file is /etc/dahdi/system.conf
    line 0: Unable to open master device '/dev/dahdi/ctl'

    1 error(s) detected

    # usr/sbin/dahdi_genconf
    Empty configuration -- no spans
    /sbin/dahdi_span_assignments: Missing '/sys/bus/dahdi_devices/devices' (DAHDI driver unloaded?)
    Command failed (status=256): 'dahdi_span_assignments dumpconfig > /etc/dahdi/assigned-spans.conf' at /usr/share/perl5/Dahdi/Config/Gen/Assignedspans.pm line 40.

     

    # systemctl status dahdi
    ● dahdi.service - LSB: DAHDI kernel modules
    Loaded: loaded (/etc/rc.d/init.d/dahdi; bad; vendor preset: disabled)
    Active: active (exited) since Mon 2020-09-07 21:45:57 CEST; 37min ago
    Docs: man:systemd-sysv-generator(8)

    Sep 07 21:45:57 pbx.hostname systemd[1]: Starting LSB: DAHDI kernel modules...
    Sep 07 21:45:57 pbx.hostname dahdi[1152]: No DAHDI modules on the system. Not starting
    Sep 07 21:45:57 pbx.hostname systemd[1]: Started LSB: DAHDI kernel modules.

    Digium cards are correctly seen by lspci as “Tiger Jet Network….”

    I used to have a trixbox (which sadly died, so I decided to switch to VitelPBX), on which the card worked, I do recall that it required zaptel drivers, and I had to go through a manual setup proces?

    Anyone here who can share some tips or a solution?

     

     

    • This topic was modified 1 month, 2 weeks ago by litebit.
    0
Viewing 1 replies (of 1 total)
  • Replies
    litebit
    Participant
    Up
    0
    Down
    No one who had similar issues?
    0
Viewing 1 replies (of 1 total)

Tagged: , , ,

  • You must be logged in to reply to this topic.