VitalPBX on AWS EC2 – NO AUDIO

VitalPBX Community Support General Discussion VitalPBX on AWS EC2 – NO AUDIO

  • Post
    Pierfrancesco Elia
    Participant

    Hi everyone, 

    I’ve just installed VitalPBX on AWS EC2. I’ve set up Security Group as shown here, also I have an AWS Elastic IP, which points statically to my instance.

    I can connect my Extensions, correctly set-up Time Conditions, Ring Groups and Announcements, I only have a problem: audio.

    To recap: I have a Static Public IP for my Instance which is located at Frankfurt, and my phones are in my Home Network, so two different places.

    When I try to call an external number (my mobile phone), the call lasts 5-10 seconds and then it fails. I’ve also set up codecs supported by VoIP providers. I believe that this is a NAT problem.

    In every part of the system (Trunks, Extensions) NAT is set to Default.

    In Settings > SIP Settings, NAT is set to Force, Comedia and External Address is set to the AWS Elastic IP.

    Can anyone help me? I don’t have any other idea.

    Thanks a lot.

    0
Viewing 1 replies (of 1 total)
  • Replies
    Up
    0
    Down

    You may install the sngrep tool in order to get a full call trace for determinating what is happening, is an error with the tunk configuration.

    yum install sngrep -y
    0
Viewing 1 replies (of 1 total)

Tagged: , ,

  • You must be logged in to reply to this topic.