VitalPBX on Dedicated server – No NAT – No sound

VitalPBX Community Support General Discussion VitalPBX on Dedicated server – No NAT – No sound

  • Post
    analyser
    Participant

    I am able to call from one SIP extension to another but no voice is transmitted, either from caller or from the other end to the caller.

    There is no NAT configuration, no Firewall whatsoever (i asked and verified with the Hosting company that they should disable any Firewall instances for my server – They did.). I have just one public IP which is not being filtered by anything.

    Where should i start looking for problems with the sound?

    Sorry, i am new to VitalPBX, and PBX in general.

    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • Replies
    Up
    0
    Down

    Are you making local calls or Outgoing / Incoming Calls?

    0
    analyser
    Participant
    Up
    0
    Down

    I have 2 SIP extensions on the server, and I am calling from my PC (using X-Lite) to my Phone (using Zoiper Free). Both are registered with the server, and both can make calls.

    0
    Up
    0
    Down

    Both extensions are in the same network that the server? are not remote phones?

    0
    analyser
    Participant
    Up
    0
    Down

    The server is remote, rented from a Hosting company. Both soft phones are in my home network.

    0
    Up
    0
    Down

    You must configure the NAT Settings on SIP Settings module under the Network tab, as shown in the picture attached

    0
    analyser
    Participant
    Up
    0
    Down

    I did but I still don’t have any voice transferred. I “saved” and “applied changes” from the top-right red icon.

    0
    Up
    0
    Down

    You have to check if in your router you are allowing the port 5060 and the ports from 10000 – 20000 for audio packages

    0
    analyser
    Participant
    Up
    0
    Down

    Hello again, thank you for helping me out. The Ports are not blocked.

    Screenshot included..

    0
    Up
    0
    Down

    What about your home network? Did you already check your router?

    0
    DannyLarsen
    Participant
    none
    Up
    0
    Down

    I am testing a similar issue, on both a dedicated and a hosted server that are offsite from where my phone or softphone is. VitalPBX ext set to Force, Comedia

    When using the Xlite phone I have no audio, I have been playing with the stun, rtp, ports etc on the Xlite. Also may be an issue with your pc firewall settings 

    When using a Yealink T46 I have audio on both the dedicated and hosted offsite server and all is well.

    When testing the Xlite to a server at the same location on a local network  I have audio and all is well, so it is either a pc firewall issue or a setting in the Xlite. 

    Same on a 3CX softphone no audio unless on the same local network.

     

    0
    Up
    0
    Down

    Danny, do you have configured the External and Local Networks in your Server?

    0
    DannyLarsen
    Participant
    none
    Up
    0
    Down

    Yes I do

    Testing two offiste servers (from where my softphones and Yealink phones are) one is hosted on vultr and one is dedicated behind a mikrotik router

    Yealink T46 works in all scenarios

    Xlite and 3cx softphones no audio on a win10 box

    I just tested a Linphone softphone on a Linuxmint box on the same network and it is working in all scenarios

    Also just tested to a Elastix box offsite at a working customer same issue

    Don’t think the problem is VitalPBX, must be a win10 thing

     

     

    0
    Up
    0
    Down

    May you send us a trace from Wireshark to analyze it?

    miguel@vitalpbx.com

    0
    analyser
    Participant
    Up
    0
    Down

    Ok, I assume that  I can check the router as well but… how can I have the SIP account everywhere? I mean, what if I am online with 4g or from a Wifi that I don’t have access to the router? Is a STUN server a possible solution for my  issue?

    0
    Up
    0
    Down

    You may use a VPN Server. VitalPBX has an add-on for configuring a VPN Server and its clients.

    Check all the info in the following link: https://vitalpbx.org/en/openvpn-integration/

    0
Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.