VitalPBX with SIP trunk to Cisco 2800 router

VitalPBX Community Support General Discussion VitalPBX with SIP trunk to Cisco 2800 router

Up
0
Down
  • Post
    pgoris
    Participant

    Hello,

    Does anyone have the configuration to connect a VitalPBX with a Cisco router? My router has several FXO ports with active lines, which I must maintain before migrating completely to SIP Trunk.


    I currently own a server with FreePBX 14 connected to the router, without any problems, but I have not managed to connect my VitalPBX server.

    Thank you

     

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • Replies

    How did you connect the FreePBX with your CISCO router? through SIP trunking?

    0
    pgoris
    Participant

    Hi MRivera,

    Yes, I use sip trunk for the connection. This is the FreePBX configuration:

    (General)
    Trunk Name : MyCiscoRouter
    Hide CallerID : No
    Outbound CallerID : 212XXXXXXX
    CID Options : Allow Any CID
    Maximum Channels : 6
    Asterisk Trunk Dial Options : T / System
    Continue if Busy : No
    Disable Trunk : No
    Monitor Trunk Failures : No
     
    (Sip Settings)
    [Outgoing]
    Trunk Name : Cisco2811
    PEER Details:
       context=from-internal
       host=192.XX.XX.XX
       type=friend
       qualify=yes
       dtmfmode=rfc2833
       disallow=all
       allow=ulaw&alaw
       nat=no
       insecure=very
     
    [Incoming]
    USER Context : from-internal
    USER Details :
       type=friend
       context=from-trunk
       host=192.XX.XX.XX
       dtmfmode=rfc2833
       disallow=all
       allow=ulaw&alaw
       nat=no
       canreinvite=no
       qualify=yes
    Register String : (blank)
     
    Thanks you
     
     
    0
    pgoris
    Participant

    This is my Cisco configuration:

    ———
    version 15.1
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname myrouter
    !
    boot-start-marker
    boot system flash:c2801-ipvoicek9-mz.151-4.M7.bin
    boot-end-marker
    !
    !
    logging buffered 51200
    !
    no aaa new-model
    !
    !
    clock timezone NewYork -5 0
    clock summer-time NewYork date Apr 6 2003 2:00 Oct 26 2003 2:00
    dot11 syslog
    ip source-route
    !
    !
    !
    !
    !
    ip cef
    no ip bootp server
    no ip domain lookup
    ip domain name globalfoundationdd.net
    ip name-server 8.8.8.8
    ip name-server 8.8.4.4
    no ipv6 cef
    multilink bundle-name authenticated
    !
    trunk group NY-Verizon
    !
    !
    !
    voice service voip
     allow-connections h323 to h323
     allow-connections h323 to sip
     allow-connections sip to h323
     allow-connections sip to sip
     signaling forward unconditional
     sip
      bind control source-interface FastEthernet0/1.1
      bind media source-interface FastEthernet0/1.1
    !
    voice class codec 1
     codec preference 1 g729r8
     codec preference 2 g711ulaw
    !
    voice class codec 2
     codec preference 1 g711ulaw
     codec preference 2 g729r8
    !
    voice-card 0
     dsp services dspfarm
    !
    crypto pki token default removal timeout 0
    !
    !
    !
    !
    license udi pid CISCO2801 sn XXXXXXXXXXX
    !
    interface Loopback0
     ip address 192.XX.XX.XX 255.255.255.224
    !
    interface FastEthernet0/0
     description ***** Link to INTERNET *****
     ip address XX.XX.XX.XX 255.255.255.0
     ip nat outside
     ip virtual-reassembly in
     shutdown
     duplex auto
     speed auto
    !
    interface Service-Engine0/0
     ip unnumbered Loopback0
     service-module ip address 192.XX.XX.XX 255.255.255.224
     service-module ip default-gateway 192.XX.XX.XX
    !
    interface FastEthernet0/1
     description ***** Link to Switch(F0/01) *****
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet0/1.1
     description ***** Data Subinterface *****
     encapsulation dot1Q 1 native
     ip address 192..XX.XX.XX 255.255.255.0
    !
    interface FastEthernet0/1.10
     description ***** VoIP Subinterface *****
     encapsulation dot1Q 10
     ip address 192..XX.XX.XX 255.255.255.0
     h323-gateway voip interface
     h323-gateway voip bind srcaddr 192.XX.XX.XX
    !
    ip forward-protocol nd
    !
    !
    no ip http server
    no ip http secure-server
    !
    logging 192.XX.XX.XX
    !
    control-plane
    !
    !
    voice-port 0/2/0
     trunk-group NY-Verizon 1
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/2/1
     trunk-group NY-Verizon 5
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/2/2
     trunk-group NY-Verizon 4
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/2/3
     trunk-group NY-Verizon 3
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/3/0
     trunk-group NY-Verizon 2
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/3/1
     trunk-group NY-Verizon 6
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/3/2
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    voice-port 0/3/3
     connection plar 5555
     description 2125555555
     caller-id enable
    !
    !
    no mgcp package-capability res-package
    no mgcp package-capability fxr-package
    no mgcp timer receive-rtcp
    no mgcp explicit hookstate
    !
    mgcp profile default
    !
    !
    dial-peer voice 100 pots
     trunkgroup NY-Verizon
     numbering-type unknown
     destination-pattern .T
     incoming called-number .
     direct-inward-dial
    !
    dial-peer voice 200 voip
     numbering-type unknown
     destination-pattern 55..
     session protocol sipv2
     session target ipv4:192.XX.XX.XX:5160 [IP FREEPBX]
     session transport udp
     dtmf-relay rtp-nte
     codec g711ulaw
     no vad
    !
    !
    gateway
     timer receive-rtp 1200
    !
    sip-ua
     retry invite 3
     retry response 3
     retry bye 3
     retry cancel 3
     timers trying 1000
     sip-server ipv4:192.XX.XX.XX [IP FREEPBX]
    !
    !
    alias exec ct config t
    alias exec sr show run
    banner login ^CCCCAuthorized access only!
     Disconnect IMMEDIATELY if you are not an authorized user!
    ^C
    banner motd ^CCCC
                    AUTHORIZED ACCESS ONLY
          This system is the property of GFDD.
      UNAUTHORIZED ACCESS TO THIS DEVICE IS PROHIBITED.
      You must have explicit permission to access this
      device.  All activities performed on this device
      are logged.  Any violations of access policy will
      result in disciplinary action.
    ^C
    !
    line con 0
    line aux 0
    line 66
     no activation-character
     no exec
     transport preferred none
     transport input all
     transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
    line vty 0 4
     transport input all
    !
    scheduler allocate 20000 1000
    ntp update-calendar
    ntp server 192.XX.XX.XX prefer
    end
     
    ——
     
    Thank you
     
     
    0

    You may create a trunk on VitalPBX in text mode:

    • First go to the trunks module (PBX >> External >> Trunks)
    • Select the desired trunk Technology (SIP)
    • Click the button labeled “Switch to Text Mode”, located at the left bottom corner.

    Your configuration should look like shown in the attached picture.

    Make sure you have configured the CISCO with VitalPBX’s IP and any other required settings.

    0
Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.