VitXi WebRTC redo setup

VitalPBX Community Support General Discussion VitXi WebRTC redo setup

  • Post
    Matt Rizkowsky
    Participant
    US
    So I couldn’t get the WebRTC setup to work, I then inspected the setup guide again and realized that I messed up the settings.
    How can I delete all those settings and redo the setup process?
    0
Viewing 15 replies - 1 through 15 (of 15 total)
  • Replies
    Matt Rizkowsky
    Participant
    US
    Up
    -1
    Down
    I figured out what to delete and got it setup correctly, however the extension won’t register.
    under extension enable push is not an option
    also whenever I enable ICE support I don’t get audio on an outbound call.
    Attachments:
    You must be logged in to view attached files.
    0
    Matt Rizkowsky
    Participant
    US
    Up
    -1
    Down
    BUMP
    0
    Matt Rizkowsky
    Participant
    US
    Up
    -1
    Down
    I suspect this is related to PJSIP devices not being allowed to connect.
    I confirmed that all the firewall settings are correct.
    What am I missing?
    0
    Matt Rizkowsky
    Participant
    US
    Up
    -1
    Down
    I got it to register and make a call and receive a call – but no audio.
    0
    Matt Rizkowsky
    Participant
    US
    Up
    -1
    Down
    No audio when doing dial by name or direct voicemail as well.
    0
    Matt Rizkowsky
    Participant
    US
    Up
    -4
    Down
    This reply has been marked as private.
    0
    Matt Rizkowsky
    Participant
    US
    Up
    0
    Down
    Please assist with the no audio issue.
    Thanks
    0
    PitzKey
    Participant
    US
    Up
    0
    Down
    Can you please show us the profile settings?
    0
    Maynor Peralta
    Keymaster
    NI
    Up
    1
    Down
    We have recently released a new version of VitXi WebRTC to fix several issues.
    0
    Maynor Peralta
    Keymaster
    NI
    Up
    1
    Down
    Check that the extensions you have configured as “VitXi Client” have the codecs described in the documentation selected.

    You can check your settings in our online guide, page 7: VitXi Manual – PDF

     

     

    0
    Matt Rizkowsky
    Participant
    US
    Up
    0
    Down
    When I turn on ICE Support in RTP settings all of my calls get no audio.
    Attachments:
    You must be logged in to view attached files.
    0
    Maynor Peralta
    Keymaster
    NI
    Up
    0
    Down
    Try setting by changing the Transport to WSS in the profile settings.

    Also verify that you have the following settings in RTP settings:

     

     

    0
    Matt Rizkowsky
    Participant
    US
    Up
    0
    Down
    When I turn on ICE Support in RTP Settings I get no audio.
    0
    Matt Rizkowsky
    Participant
    US
    Up
    0
    Down
    With ICE support off I at least get audio on everything that isn’t WebRTC
    0
    mo10
    Moderator
    none
    Up
    0
    Down
    From Telegram group:

    You must use WebRTC profile for VitXi and the default PJSIP profile for the rest of phones. You cannot use the WebRTC profile for regular phones.

    FYI: you can add another device with different profile. See picture attached.

     

    Attachments:
    You must be logged in to view attached files.
    0
Viewing 15 replies - 1 through 15 (of 15 total)

Tagged: 

  • You must be logged in to reply to this topic.