[VOIPTALK] Does VitalPBX support outbound proxies?

VitalPBX Community Support General Discussion [VOIPTALK] Does VitalPBX support outbound proxies?

Up
0
Down
  • Post
    davej
    Participant

    I have setup my voip providers details in the peer parameters and outgoing calls work ok.

    I am behind a NAT router and the connection by proxy is meant to stop the requirement of opening up ports on my router.

    My connection below works for outgoing calls but when I look in the logs it seems that there is no reference to the outboundproxy. Is this supported by VitalPBX?

    type=friend
    username=XXXXXXXX
    secret=123456
    dtmfmode=rfc2833
    host=voiptalk.org
    outboundproxy=nat.voiptalk.org
    port=5065
    fromuser=XXXXXXX
    fromdomain=voiptalk.org
    usereqphone=yes
    canreinvite=no

    Thanks

    0
Viewing 9 replies - 1 through 9 (of 9 total)
  • Replies

    If Asterisk support it, VitalPBX too

    0
    davej
    Participant

    Thanks for your reply.

    I have looked everywhere for the solution to the outgoing proxy. I have found instructions for connecting to an Asterisk server as follows but with no luck

    [general]
    	register => 844XXXX:xxxxx:844XXXX@voiptalk/844XXXX
    	
    	[voiptalk]
    	type=friend
    	username=844XXXX
    	secret= xxxxx
    	dtmfmode=rfc2833
    	host=voiptalk.org
    	;Below is will be the context you will use to receive incoming calls in extension.conf
    	context=voiptalk_incoming
    	outboundproxy=nat.voiptalk.org
    	port=5065
    	fromuser=844XXXX
    	fromdomain=voiptalk.org
    	usereqphone=yes
    	canreinvite=no

    The proxy never shows as connecting in the logs the only error I get is the following;

    <————->
    [2018-11-02 08:52:56] VERBOSE[1790] chan_sip.c: — (8 headers 0 lines) —
    [2018-11-02 08:52:56] VERBOSE[1790] chan_sip.c:
    <— SIP read from UDP:77.240.48.94:5060 —>
    SIP/2.0 401 Unauthorized
    Via: SIP/2.0/UDP 192.168.1.6:5060;branch=z9hG4bK31eaf7c6;rport=5060;received=*.*.*.*
    From: <sip:844******@voiptalk.org>;tag=as42496865
    To: <sip:844******@voiptalk.org>;tag=c97b4d1cb1f3d0da549e06a8d482ef63.d515
    Call-ID: 7fe2e8a67c3b8d932acf5b0f13acae90@[fe80::20c:29ff:fe7d:a5d3]
    CSeq: 124 REGISTER
    WWW-Authenticate: Digest realm=”voiptalk.org”, nonce=”5bdc1086000125754b69626c521a0151d6338ee4d15b71ec”, stale=true
    Server: OpenSIPS (1.5.3-notls (x86_64/linux))
    Content-Length: 0

    <————->

    I have connected with a 3CX system no problem but prefer VitalPBX as its cheaper ? 

    0

    The outbound proxy parameter is for send outbound signaling through the Proxy, that means that only works for outgoing calls and does nothing to do with incoming calls.

    To configure NAT settings, you can go to the SIP Settings form under Network Tab and configure your NAT settings with your External and local address.

    I am attaching you an example of a trunk with voiptalk. Outgoing and Incoming calls working as expected

    0
    davej
    Participant

    Thanks for your indepth reply. It seems that you are avoiding the use of a proxy and therfore reliant on the port forwarding from the router.

    By using an outbound proxy there is no need to use port forwarding and the possible security implications that in entails.

    If this is the only way of making it work I may look into what is needed but it does mean a lot of forwarded ports.

     

    Thanks

    0

    Due I am using the visual mode, I set the outbound proxy under advanced Tab, however, the trunk is still working as expected. What is your issue with the Incoming cal?  There is not sound in the calls?

    0
    davej
    Participant

    I have recreated the Trunk with exactly the same settings as you have shown using my account/password and the phone as usual dials out with no problem and the sound can be heard ok from both directions.

    The issue seems to be that I dont get any inbound calls. Do you have port forwarding set on your router or does your pbx sit on an external IP address?

     

    Thanks

     

    0
    davej
    Participant

    I think I have now found the problem as VitalPBX is now showing the outbound proxy in the logs but rather than connecting the remote server is offering options and therfore disconnects.

    ———- SIP HISTORY for ’49d2eaa1082c86065e49ab7117afe932@192.168.1.6:5060′
    [2018-11-05 10:37:08] DEBUG[1792] chan_sip.c: * SIP Call
    [2018-11-05 10:37:08] DEBUG[1792] chan_sip.c: 001. OBproxy Using peer obproxy nat.voiptalk.org
    [2018-11-05 10:37:08] DEBUG[1792] chan_sip.c: 002. TxReqRel OPTIONS / 102 OPTIONS – OPTIONS
    [2018-11-05 10:37:08] DEBUG[1792] chan_sip.c: 003. Rx SIP/2.0 / 102 OPTIONS / 403 Forbidden – no OBP
    [2018-11-05 10:37:08] DEBUG[1792] chan_sip.c: 004. NeedDestroy Setting needdestroy because got OPTIONS response
    [2018-11-05 10:37:08] DEBUG[1792] chan_sip.c:
    ———- END SIP HISTORY for ’49d2eaa1082c86065e49ab7117afe932@192.168.1.6:5060′

     

    Is there somewhere I can look to see in more depth what option I have not given the remote server?

     

    Thanks

    0

    Did you follow this instructions: https://www.voiptalk.org/products/asterisk-voiptalk-sip-trunk-registration-using-outbound-proxy-setup

    0
    davej
    Participant

    Yes, I even did a fresh install and set it up again.

    I will see if VoipTalk can give me any ideas. I have an outstanding ticket raised.

     

    Thanks

    0
Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.