WEB GUI DOWN – Vital PBX

VitalPBX Community Support Reporting an Issue WEB GUI DOWN – Vital PBX

  • Post
    soliman99
    Participant
    Up
    0
    Down
    The Web GUI is down .

    After attempt to install communicator from add-ons . the progress bar not completed . and we completely cannot access Web GUI .

    Asterisk service is working and the SSH also but the web GUI is down on both HTTP/S

    Any Help

    0
Viewing 15 replies - 1 through 15 (of 18 total)
  • Replies
    Gary
    Participant
    Up
    1
    Down
    I just had the same thing, upgrading from the gui to 3.0.8-1 and the gui stoped working, funny thing is I can access mydomain.com/recordings but not mydomain.com ?
    0
    Up
    0
    Down
    Check if the HTTP/Apache service is up and running.
    0
    Gary
    Participant
    Up
    0
    Down
    [root@vitalpbx3 ~]# systemctl status httpd.service
    ● httpd.service – The Apache HTTP Server
    Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
    Active: active (running) since Tue 2021-04-20 21:31:24 EDT; 3h 12min ago
    Docs: man:httpd(8)
    man:apachectl(8)
    Process: 4185 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=0/SUCCESS)
    Process: 6955 ExecReload=/usr/sbin/httpd $OPTIONS -k graceful (code=exited, status=0/SUCCESS)
    Main PID: 4189 (httpd)
    Status: “Total requests: 0; Current requests/sec: 0; Current traffic: 0 B/sec”
    CGroup: /system.slice/httpd.service
    ├─4189 /usr/sbin/httpd -DFOREGROUND
    ├─6967 /usr/sbin/httpd -DFOREGROUND
    ├─6968 /usr/sbin/httpd -DFOREGROUND
    ├─6969 /usr/sbin/httpd -DFOREGROUND
    ├─6970 /usr/sbin/httpd -DFOREGROUND
    ├─6971 /usr/sbin/httpd -DFOREGROUND
    └─7712 /usr/sbin/httpd -DFOREGROUND

    Apr 20 22:54:09 vitalpbx3 sudo[6615]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 22:54:09 vitalpbx3 sudo[6623]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 22:54:09 vitalpbx3 sudo[6630]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 22:54:10 vitalpbx3 sudo[6639]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 22:54:10 vitalpbx3 sudo[6646]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 22:54:40 vitalpbx3 sudo[6659]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 22:54:40 vitalpbx3 sudo[6666]: apache : TTY=unknown ; PWD=/usr/share/vitalpbx/www ; USER=root ; COMMAND=/sbin/vpbx-helper
    Apr 20 23:07:36 vitalpbx3 systemd[1]: Reloading The Apache HTTP Server.
    Apr 20 23:07:36 vitalpbx3 httpd[6955]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using fe80::5400:2ff:…s message
    Apr 20 23:07:36 vitalpbx3 systemd[1]: Reloaded The Apache HTTP Server.
    Hint: Some lines were ellipsized, use -l to show in full.
    [root@vitalpbx3 ~]#

    0
    Up
    0
    Down
    Try enabling the PHP debug to see if you get a better picture of what is happening with the GUI.

    Edit the PHP.ini file and edit the parameters as shown in the attached screenshot.

    • vim /etc/php.ini
    • Edit the parameters
    • Restart the apache service: systemctl reload-or-restart httpd

    After doing the above, try entering the VitalPBX’s GUI to see if there’s any hint about the error you are having.

    Attachments:
    You must be logged in to view attached files.
    0
    soliman99
    Participant
    Up
    0
    Down
    Done and still the page didn’t load at all
    0
    Up
    0
    Down
    Do you get some error when trying to access? Maybe the update didn’t finish correctly.
    0
    soliman99
    Participant
    Up
    0
    Down
    Not Displaying any error only not loading , I think the add-on not installed correctly also .

    Ok how to rebuild the Web GUI to able to access it again

    0
    Gary
    Participant
    Up
    0
    Down
    Same here just a blank screen.  I can get to mydomain.com/recordings so something is working.

     

    Attachments:
    You must be logged in to view attached files.
    0
    Gary
    Participant
    Up
    0
    Down
    Some how this is also prenventing inbound routes from sip trunk, we can call out but no inbound ?
    0
    Gary
    Participant
    Up
    0
    Down
    Soliman:

    By any chance do you have Lets Encrypt activated, I see a error in httpd status.

    vitalpbx3 httpd[1193]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using fe80::5400:2ff:xxxx:xxxx. Set the ‘ServerName’ directive globally to suppress this message

    0
    soliman99
    Participant
    Up
    0
    Down
    Gary

    No the server is without let’s encrypt

    0
    soliman99
    Participant
    Up
    0
    Down
    The Issue Repeted on 2 seperated lab servers . when tring to install Communicator addon from add-ons tab the server get error and after rebooting the WEB GUI is down .

    Appreatiate to help

    0
    soliman99
    Participant
    Up
    0
    Down
    after removing the communicator from the terminal the GUI start working

    yum remove -y vitalpbx-communicator-3.0.1-1.x86_64

    0
    soliman99
    Participant
    Up
    0
    Down
    Kindly check the Dependencies if there is an error on the package

    vitalpbx-communicator-3.0.1-1.x86_64

    0
    Gary
    Participant
    Up
    1
    Down
    Thanks soliman99 that command also fixes my gui issue as well.
    0
Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.