Bryan

Forum Replies Created

Viewing 9 replies - 1 through 9 (of 9 total)
  • Replies
  • Bryan
    Participant
    Up
    0
    Down
    I agree with Dan.  The Addons page is a mine field.  Just ran into this myself and am having to reinstall again.
    0
    Bryan
    Participant
    Up
    0
    Down
    In response to your question Jose…

    Below is an example of what fails:

    http://127.0.0.1:82/CID?name=%5BCIDNAME%5D&number=%5BCIDNUM%5D

    I can make it work by hardcoding in values, like:

    http://127.0.0.1:82/CID?name=John%20Smith&number=12345678901

    Also… are there other parameters in addition to those two?

    Thanks,

    Bryan

    0
    Bryan
    Participant
    Up
    0
    Down
    Awesome.  Thanks providing that.
    0
    Bryan
    Participant
    Up
    0
    Down
    Ok… evidently the every time I try to respond, the message board flags it for moderation… probably because it detects that full URLs are in the message… which wouldn’t be so bad except that it seems that no one is moderating the moderated posts.  I’ve even tried modify the URLs so they aren’t usable URLs, yet the system is still not allowing those messages to go through.

    So… since it seems to be fine with a screenshot, the attached screenshot is the message is what I’m trying to reply with.

     

    Attachments:
    You must be logged in to view attached files.
    0
    Bryan
    Participant
    Up
    0
    Down
    Could you share how you went about doing this?  I’d like to have ARI working as well.
    0
    Bryan
    Participant
    Up
    1
    Down
    I definitely second this request.
    0
    Bryan
    Participant
    Up
    0
    Down
    I have the original PhoneBridge integration for Asterisk working with Zoho Desk.  The good news is that it does work, but is not the most intuitive solution, and it needs a little finessing, being that it was originally written for Asterisk 1.4.

    I should also mention that it remains uncertain as to how much longer Zoho will be supporting this version, as they’ve made it pretty clear that they don’t plan to continue to support individual users using Asterisk, and moving forward they will only be willing to support development efforts being made on behalf of a voip hardware/software company (like VitalPBX) or voip cloud solution, or a voip service provider, etc.

     

    0
    Bryan
    Participant
    Up
    0
    Down
    Hello,

    I’m not certain, but it would appear that CID Modify via HTTP/HTTPS might not be URL escaping the data applied through the [CIDNAME] and [CIDNUM] placeholders, causing it to fail in most cases.

    I am able to make it partly work by replacing the variables with the actual escaped text, which demonstrates that it does consume the returned JSON data from a REST server and then accordingly replaces the CID name and number.

    -Bryan

    0
    Bryan
    Participant
    Up
    2
    Down
    Hi Maynor,

    Thanks for your reply.  That’s exactly what I was meaning.  In further testing (using Chrome on macOS Catalina Version 10.15.17), I’ve also found that VitXi can very easily “forget” its assigned audio output setting and instead use the output assigned as the system default.  I’m currently trying to see if I can determine what it is that can trigger this switch.

    Thanks,

    Bryan

    1
Viewing 9 replies - 1 through 9 (of 9 total)