slemoal

Forum Replies Created

Viewing 14 replies - 1 through 14 (of 14 total)
  • Replies
    • in reply to: Changelog
    slemoal
    Participant
    Up
    0
    Down
    Thank you it s perfect
    0
    • in reply to: Changelog
    slemoal
    Participant
    Up
    0
    Down
    Up
    0
    slemoal
    Participant
    Up
    0
    Down
    [Auto resolve V2] 😀

    NTP does not start at boot
    It looks like ntpd has been replaced by chrony.
    I had to modify:
    nano /etc/chrony.conf
    # Allow NTP client access from local network.
    allow 192.168.0.0/16
    allow 10.0.0.0/8
    allow 172.16.0.0/16

    Now it works fine

    0
    slemoal
    Participant
    Up
    0
    Down
    [Auto Resolved]
    the ntp package is not installed..

    yum install ntp
    systemctl start ntpd
    systemctl enable ntpd
    systemctl status ntpd

     

    Test OK

    0
    slemoal
    Participant
    Up
    0
    Down
    Hello, I have the same problem with an Openvox B400E BRI card
    I am in the latest version (VitalPBX 3.0.8-3)
    0
    slemoal
    Participant
    Up
    0
    Down
    Thanks Rodrigo,

    Sorry for my english from the first post, google translate also 🙂

    Do not hesitate to get in touch with David René from Rack Matrix if you want to offer VitalPBX servers or for your partners

    ___________________

    Version française:

    Merci Rodrigo,

    Désolé pour mon anglais du premier post, google translate également 🙂

    N’hésitez pas à entrer en contact avec David René de Rack Matrix si vous souhaitez proposer des serveurs VitalPBX ou pour vos partenaire

    0
    slemoal
    Participant
    Up
    0
    Down
    Version française:

     

    Retour d’experiance et présentation

    Bonjour,
    nous sommes une entreprise de 10 personnes, intégrateur téléphonique en France.
    Nous travaillons avec des distributions Asterisk depuis près de 15ans (xivo, elastix, wazo) des divergences sur le modèle économique, ou rachat nous ont forcé à nous tourner vers une nouvelle solution.
    C’est là que l’aventure VitalPBX commence 🙂

    Nous venons de réaliser avec succès nos deux premières installations VitalPBX.
    1) 4 téléphone bureau, 8 Bornes DECT, 20 combinés DECT, 2BRI

    2) 6 téléphone bureau, 12 bornes DECT, 7combinés DECT, opérateur sip (EBCS)

    Côté serveur nous avons choisi les Appliance RackMatrix permettant un niveau de personnalisation illimité (impression UV des façades personnalisables, possibilité d’intégrer des cartes FXO, FXS, BRI, PRI, switch poe, onduleur UPS, wifi, 4g…)
    Nous travaillons avec eux pour les Appliance IPBX, firewall, portail captif depuis de nombreuses années et ne pouvons que les recommander.
    https://rack-matrix.com/en/

    Téléphone fixe la gamme Fanvil X4U, X5U, X6U X210.
    Le retour installateur et utilisateurs est très positif.

    Dect: borne multicell Yealink 80DM, 80B, et w56h pour les combinés.
    Bien que l’installation soit simple et intuitive je n’ai pas apprécié le fait qu’il y ait besoin d’un contrôleur physique 80DM qui ne soit pas une borne DECT ni la gestion des clusters et niveau de synchronisation à gérer manuellement. Cette partie n’est pas pratique.

    Nous opteront donc pour les bornes RTX lors de nos prochaines installations.
    RTX gèrent également le RSyncLAN.

    Le w56h est très grand, avec du recul je partirai sur le modèle W53h
    Côté utilisateurs l’interface est intuitive (attente, transfert, double appel).

    VitalPBX, des distributions asterisk que nous connaissons c’est de loin la plus complète et intuitive.
    Plusieurs options sont très pratiques comme la visualisation de l’état des renvois de l’ensemble des extensions, le fait de pouvoir écouter les musiques depuis l’interface…

    Nos 2 premières installations sont donc une réussite et nous tenons à remercier toutes l équipes VitalPBX pour leurs travail et réactivité lors de nos différents échanges par mail et forum.

    Tout projet aillant besoin d’un modèle économique pour être viable, j’ai beaucoup apprécié le fonctionnement en module proposé. Pour aller plus loin nous avons décidé de réaliser un don ou achat de module systématique d’un minimum de 50$ pour les installations à moins de 30 extensions et 100$ au-delà.
    Ce n’est pas énorme, mais sur l’ensemble des utilisateurs VitalPBX ça rend le modèle économique viable.

    Attachments:
    You must be logged in to view attached files.
    0
    slemoal
    Participant
    Up
    0
    Down
    Hello, you will find attached the configuration procedure with the sewan operator, and the definitive workaround for the did in the to field

    Tutorial

    0
    slemoal
    Participant
    Up
    0
    Down
    hello can you call and be called?

    if yes so when you answer does the call hang up? if not,  it’s more of an rtp stream problem. did you open these? port from 10000 to 20000. are you using srtp?

    0
    slemoal
    Participant
    Up
    0
    Down
    After several tries with Rodrigo (again thank you for your time) the problem comes from the rule: “_ [+ * # 0-9A-Za-z].” which does not match needing at least 2 characters.
    Excluding after analysis of the traces we only receive the “s” the DID being subsequently retrieved in the TO field

    The workaround is as follows:

    nano /etc/asterisk/vitalpbx/extensions__50-1-dialplan_custom.conf

    add dialplan

    [trk-1-in-custom]
    exten => _.,1,NoOp(Incoming call through: Trunk_sip_Sewan)
    same => n,Set(__TRUNK_ID=1)
    same => n,Set(CDR(trunk)=1)
    same => n,Set(__DID_NUMBER=${EXTEN})
    same => n,Set(CDR(did)=${EXTEN})
    same => n,Set(DID=${EXTEN})
    same => n,Set(DID=${IF($["${CHANNEL(channeltype)}"="SIP"]?${CUT(CUT(SIP_HEADER(To),@,1),:,2)}:${CUT(CUT(PJSIP_HEADE$
    same => n,Goto(default-trunk,${DID},1)

    put the rights

    chmod +x /etc/asterisk/vitalpbx/extensions__50-1-dialplan_custom.conf

    In the advanced tab of the trunk, Custom Settings

    type=peers
    parameter= context 
    value= trk-1-in-custom

    This procedure must be valid for all SIP operators which indicate the DID in the TO field (like OVH)

    en français:

    Apres plusieurs essai avec Rodrigo (encore merci pour votre temps) le probleme vient bien de la règle: “_[+*#0-9A-Za-z].” qui ne matche pas ayant besoin de 2 caractères minimum.
    Hors après analyse des trace nous ne recevons que le “s” le DID étant récupéré par la suite dans le champs TO

    La solution de contournement est la suivante:

    créer un fichier custom

    nano /etc/asterisk/vitalpbx/extensions__50-1-dialplan_custom.conf

    Ajouter le dialplan ci-dessous

    [trk-1-in-custom]
    exten => _.,1,NoOp(Incoming call through: Trunk_sip_Sewan)
    same => n,Set(__TRUNK_ID=1)
    same => n,Set(CDR(trunk)=1)
    same => n,Set(__DID_NUMBER=${EXTEN})
    same => n,Set(CDR(did)=${EXTEN})
    same => n,Set(DID=${EXTEN})
    same => n,Set(DID=${IF($["${CHANNEL(channeltype)}"="SIP"]?${CUT(CUT(SIP_HEADER(To),@,1),:,2)}:${CUT(CUT(PJSIP_HEADE$
    same => n,Goto(default-trunk,${DID},1)

    Mettre les droits d’exécution

    chmod +x /etc/asterisk/vitalpbx/extensions__50-1-dialplan_custom.conf

     

    Dans l’onglet avancé du trunk, Custom Settings

    type=peers
    parameter= context 
    value= trk-1-in-custom

    Cette procédure doit être valable pour tout les opérateurs SIP qui indique le DID dans le champs TO (comme OVH)

    0
    slemoal
    Participant
    Up
    0
    Down
    I found the “bug”
    /etc/asterisk/vitalpbx/sip__50-1-trunks.conf
    [trunkxxxxx](p13)
    context=trk-1-in
    description=Trunk_sip_Sewan
    dtmfmode=rfc2833
    allow=!all,alaw,ulaw,g729
    nat=no
    host=37.97.65.78
    port=5070
    secret=ppppp
    insecure=port,invite
    defaultuser=trunkxxxxx
    remotesecret=ppppp
    fromdomain=yyyy.sewan.eu
    qualify=yes
    type=peer

    /etc/asterisk/vitalpbx/extensions__50-1-dialplan.conf

    My trunk has the context: [trk-1-in]

    [trk-1-in]
    exten => _[+*#0-9A-Za-z].,1,NoOp(Incoming call through: Trunk_sip_Sewan)
    same => n,Set(__TRUNK_ID=1)
    same => n,Set(CDR(trunk)=1)
    same => n,Set(__DID_NUMBER=${EXTEN})
    same => n,Set(CDR(did)=${EXTEN})
    same => n,Set(DID=${EXTEN})
    same => n,Set(DID=${IF($["${CHANNEL(channeltype)}"="SIP"]?${CUT(CUT(SIP_HEADER(To),@,1),:,2)}:${CUT(CUT(PJSIP_HEADER(read,To),@,1),:,2)})})
    same => n,Goto(default-trunk,${DID},1)

    if I change the first line to:
    exten => _.,1,NoOp(Incoming call through: Trunk_sip_Sewan)
    and that I reload the dialplan in CLI it works.
    The problem is that as soon as I modify in GUI it regenerates the plan of num with the problem …

    • This reply was modified 5 months, 1 week ago by slemoal.
    0
    slemoal
    Participant
    Up
    0
    Down
    if in my inbound route I put “_X.”

    then it doesn’t work. I have the message:

    voice*CLI>
    == Using SIP RTP TOS bits 184
    == Using SIP RTP CoS mark 5
    voice*CLI>

     

    But if I put: “_.”
    So there I get the call.

    Which leads me to think that my first character is not a number…

     

     

     

     

    0
    slemoal
    Participant
    Up
    0
    Down
    Hello and thank you for your help.
    As you will see in the screenshot below this is already the case.

    The only rule for making a successful call is if I put “_.”

    Attachments:
    You must be logged in to view attached files.
    0
Viewing 14 replies - 1 through 14 (of 14 total)